Best answer

Zapier Tables Error code 400: Error found at request.body.payload.record_id: Cannot create ULID from string of length 8 (general:validation_error)

  • 25 April 2024
  • 5 replies
  • 111 views

Userlevel 1

 

I can’t seem to figure out why I continue to get this error. I simply want to update a record in a table based on contact info from my CRM. Ignore the additional paths, I will clean those up later. 

I will start with the error I am receiving at Step 13, then back it up to where the data is starting to be pulled from.

 

 

Step 10 finds data in my CRM by using the Client ID linked to the Task (that was created in the CRM) that starts the whole Zap.
The static data I am looking for in my CRM comes over as a custom field. I need the custom field value of ‘3 Months’ to create a new task to end this zap

 

At this point, I found that Zapier does not like my custom data fields so I have to format the data in steps 11 and 12, otherwise Step 13 is trying to update a record with a string that looks like what I have highlighted in yellow in the screenshot below. I have multiple custom field values in my CRM. The meeting cadence just happens to be the first that zapier sees. Everything else is separated by commas.

So after cleaning the data, here is the action in Step 13 that results in the error.

 

 

 

 

icon

Best answer by Troy Tessalone 25 April 2024, 18:46

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Tcox090 

Check the field description for guidance about the expected values.

The Record ID field for Zapier Tables expects a Record ID from Zapier Tables, not from a different app.

 

@Tcox090

Zapier tables provide extra field called Record ID like for example 01ARZ3NDEKTSV4RRFFQ69G5FAV so instead of providing an existing field value you will have to use the Record ID which is like guaranteed value. so as Mr @Troy Tessalone said.  

Userlevel 7
Badge +11

Hi @Tcox090 👋

It’s been a little while since we’ve heard from you here, were you since able to get rid of that error? 

If not, you might want to try adding a Find Record (Zapier Tables) search action to get the ID of the record that the Update Record (Zapier Tables) action needs to update. If the Linked to ID value is stored in the record in Zapier Tables then you can use that in the Lookup Value field on the Find Record action.

Keen to ensure you’re all set here so please let us know how you’re getting on! 🙂

Userlevel 1

That did the trick! I was using the record field incorrectly and I didn’t realize that record ID is part of the zapier table, not data from my CRM.

Userlevel 7
Badge +11

I’m so pleased to hear that sorted it, @Tcox090. Thanks so much for following up here to confirm, it’s much appreciated! 🤗

Please do reach out in the Community again if you need help with anything else in future and in the meantime, happy Zapping! ⚡