Best answer

Zapier Resets Excel Column Width When Adding New Row

  • 12 February 2024
  • 6 replies
  • 62 views

Userlevel 1

My Zap adds a new row to an excel spreadsheet in OneDrive each time a submission is received in Gravity Forms.

The zap works as expected except that it resets the width of the columns in my spreadsheet every time it adds a row.

Viewers of the spreadsheet are unable to see the data because the columns are too narrow. Submissions come in often, so they constantly have to resize the columns while using the spreadsheet.

Is there a way to configure the Zap or the Excel spreadsheet to prevent the column width from being reset?

Steps to reproduce:

  1. Create a Zap that adds a row to an Excel Spreadsheet in OneDrive.
  2. Resize the columns of the spreadsheet manually.
  3. Run the Zap. The width of the columns will be reset.

A similar bug was reported in this thread:

 

icon

Best answer by darrian 26 March 2024, 20:22

View original

6 replies

Userlevel 7
Badge +14

Hi @darrian 

One possible workaround is to use a different app:

Userlevel 1

My team needs the form submissions in Excel.

Userlevel 7
Badge +6

Hi @darrian,

I’m jumping in to see if I can help!

Upon checking our internal notes, this should be due to Microsoft Excel settings called Autofit Column Widths on Update. Can you please check that?

I'll be keeping an eye out for your response!

Userlevel 1

Hii Guys,

I think I found a solution for the “collum width reset problem”.
 

You can change the column in Excel width in the triangle menu. 
(In the top left corner between A & 1)
 

 


There you can adjust the column width in pixels, e.g. 300.
 

If Zapier then triggers an automatism and transfers the data to the Excel table, the columns remain the same.
 

The table much prettier this way :-)

Userlevel 1

Thanks for the suggestions!

I found a workaround to prevent Zapier’s updates from resetting my excel column sizes.

I hit CTRL+A twice to select all of the cells in the sheet, then I set both the column width and row width of every cell and that worked. Using “Home” > “Cells” > “Format” > “Row Height...” and “Column Height...”

@Stefan P. Previously I was setting the column widths the way you described and that was being reset until I also set the row heights.

@ken.a I couldn’t find a setting called “Autofit Column Widths on Update”. From Googling it looks like that may only an option for Pivot Tables. But I could just be missing it.

Userlevel 7
Badge +6

Hi @darrian and @Stefan P.,

I really appreciate you all for sharing the workaround here. This will be helpful to our Community members who might have the similar issue.

Happy Zapping! ⚡️

Reply