Best answer

Zapier only pulling in the first 20 custom fields

  • 23 March 2022
  • 7 replies
  • 58 views

Hey Zapier Community,

I am encountering a problem where Zapier is only pulling in the first 20 custom fields, similarly described in this thread from 2020. According to the previous answer, this was flagged as an issue with the ManyChat Zapier integration.

I am currently trying to set a new field in ManyChat via Zapier, but Zapier is no longer able to pull in all my fields and I am unable to set the new field. I’ve attached a photo of the error message to this post.
 



How can I get Zapier to pull in all my fields from ManyChat as it previously did?

icon

Best answer by SamB 14 June 2024, 15:51

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @austinserio 

Good question.

Please clarify which ManyChat trigger/action you are trying to use in your Zap with screenshots, thanks.

 

Hi @austinserio 

Good question.

Please clarify which ManyChat trigger/action you are trying to use in your Zap with screenshots, thanks.

 

thanks for getting back to me @Troy Tessalone !

I am trying to use the “Set Custom Field in ManyChat” action, and I’ve attached a broader screenshot here.

Please let me know if additional clarification is needed!

 

 

Userlevel 7
Badge +14

@austinserio 

Try this…

If you can find the internal Custom Field ID (see smaller gray font values), then you can use the ‘Custom’ mapping option to specify the desired field.

 

 

Userlevel 7
Badge +11

Hey there @austinserio. Welcome to the Community!

It appears that the issue is still open, so I’ve added you to the list of affected folks on the existing bug report for that issue.

That said, I do see reports that reconnecting the ManyChat account got the rest of the custom fields loaded. If that doesn’t do the trick then manually selecting the custom field using the Custom value option that Troy mentioned is another good workaround to try. You can find out more about how to use the custom value option here: Add custom values to dropdown menu fields in Zaps 

Hope that helps! 🙂

Thanks for the quick support @SamB @Troy Tessalone !

Between the two suggestions I was able to come to come to a temporary solution which I wanted to share here for future community reference.

As I was unable to get the list to populate beyond the previously mentioned 20, I ended up adding in a Custom value. However, I didn’t see any documentation from ManyChat to easily identify the “custom_field:numberScheme”. 

To get around this I did the following:

  1. First reconnect Zapier and ManyChat as suggested by @SamB 
  2. Create a temporary new Zap, with the first step being a “New or Updated Custom Field in ManyChat”
  3. The “Load More” option shouldn’t be greyed out this time. Continue clicking “Load More” -- this will enable the new Zap to load the rest of the fields, thereby revealing the value of your desired field’s “custom_field:numberScheme”. After 
    1.  

  4. In the Zap you’re originally experiencing issues, enter a Custom Zapier value as described by @Troy Tessalone 

 



After these steps, I arrived in a good place for now. However, hoping the core of this issue gets cleared up soon by ManyChat.
 

Thanks again for the help @Troy Tessalone and @SamB

Userlevel 7
Badge +9

Thanks for sharing your workaround with the community, @austinserio! So glad you were able to find a solution! 🎉

Userlevel 7
Badge +11

Hey folks,

I’m pleased to announce that the ManyChat team have released a new version of their app on Zapier which should allow all custom fields to be loaded now! 😁🎉

To take advantage of this fix please ensure you’re running the latest version of the ManyChat app in your Zaps. 

That said, if you’re still experiencing issues in loading all custom fields please do reach out in the Community or get in touch with Support to let us know. In the meantime, happy Zapping! ⚡