Question

Zapier Not Moving Ad Leads from FB to Mailchimp

  • 4 August 2022
  • 4 replies
  • 21 views

Hi there, I’m new to the group and am not super technical. I generally work with paint all day, not tech. 

I’m having trouble getting my leads from my FB ad to auto-populate into Mailchimp through Zapier. This is starting the third week of troubleshooting. 

I have a paid account. 

I have no warnings on the Zap, and the test trigger goes to my Mailchimp account.

The Zap is toggled On. I've toggled it off and on again. I’ve gotten out of Zapier and logged back in. 

My ads coach has helped me se this up, and I’m the only one of her clients who is having this issue. She is well versed in setting up Zaps. We have rebuilt the Zap 3 times. 

I have read all of the troubleshooting steps, and gone back through my Zap, nothing seems to be out of place, incorrect, or turned off.  

I saw there was a glitch not that long ago on Zapier’s end, but that it has been fixed before I signed up. 

I have the correct FB account, and ad linked to Zapier. 

We’re really at a loss here. I’d appreciate help getting this figured out.

Thanks in advance, 

Susan 


4 replies

Userlevel 7
Badge +11

Hi @Susan Holt Artist!

I’m really sorry that you’re having trouble setting up your Facebook Lead Ads Zap. It sounds like the issue is that your Zap isn’t triggering from new leads, is that right? If so, the most common cause is permission settings in Facebook; there are lots of different permissions in lots of different menus so it can be very tricky!

You said that you’ve already gone through the troubleshooting steps, so I apologize if you’ve already looked at this, but this help doc  is very useful as it lists the different places that you need to check. Also, the Facebook testing tool (explained in this help guide) is really useful for finding issues. 

 

If none of those work for you, the best thing to do is to get in touch with the Zapier Support team (using the Get Help form) as they can ask you to send screenshots of how everything is set up in Facebook and can also see the logs of the Zap. 

 

Let us know if any of that helped you!

Thank you. I’ve gone back through all of this and didn’t have one button turned on. I’ll have to wait and see if the leads start going over now, and will let you know if (when) they do.

Thanks again!

Susan

Userlevel 7
Badge +9

Thanks for confirming this Susan!

I can see you were able to open a ticket with the support team - which is perfect. You’re truly in the best of hands! 

Please keep us in the loop on any progress ya’ll are able to make. We definitely want to make sure you’re all squared away with this. 

Thank you for all of the great info and guidance. Tech Support says they’ll get back to me within 24 hours. I’m looking forward to getting this working.

Susan

Reply