Best answer

Zapier not loading Asana Project

  • 25 February 2022
  • 8 replies

Userlevel 1


I’m attempting to set up a Google Form -- Asana Task Zap. I am successful with setting up the Google Form trigger, however, Zapier can’t seem to find the Asana Project. I’ve tried searching for it, restarting Asana, making different projects with different permissions, etc. Zapier still cannot find the project I want it to. The search function is either not working or I’m missing something.



Best answer by Troy Tessalone 25 February 2022, 19:50

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @amcgee 

Try clicking this button:


I'm not seeing my Project in the drop-down menu

If you're not seeing your Project listed, search for the project name in the field and click the "Check Asana & reload to bring in new choices" option:

Projects are loaded from Asana 25 at a time so if you have a large number of projects in your account it might require more than one click in order for it to show up:

Userlevel 1

Hi Troy,

Thank you for your response. I consulted this article before I opened this ticket, and I have tried this already. Firstly, I am not seeing the option that says “Check Asana & Reload to bring in new choices,” which is why I included the screenshot.

Secondly, when you say my “account” are you referring to my account specifically, as in my email address/account with Asana? Or my organization’s account? If you’re referring to the organization’s account, are you suggesting that if there are 250 projects within my organization then I would have to click Load More 10 times? And is that to say that I cannot type in the name of my Asana project and it will populate within the search results?

Userlevel 7
Badge +14


Yes, try clicking more a few times.


Userlevel 1

I guess it can be easy to underestimate how big my organization is and just how many Asana projects are populating. I think there could be hundreds. I can easily be here all day clicking ‘Load More.’

I tried your suggestion, but I am still not seeing my project populate. Is there any other way to narrow the results? I’m disappointed that the search function doesn’t work :( It looks like I will have to find a different tool to use to achieve the desired task.


Thank you.

Userlevel 7
Badge +14


In Asana, find the internal Asana ID for the Asana Project (check the browser URL), then use the ‘custom’ mapping option to place that value in the field.




Userlevel 1

Thank you, Troy! That worked!

For anyone else, who needs this solution. You can add the number within the url in the custom field and click Use.



It will populate above in the search field:


You can then click away and move on with creating your action.



Hi I been having the same problem, 

I have try all of this already, the load more and pasting the project ID, but nothing, although it works with some other projects but the one I need.


Thank you


Userlevel 1

Hi Damar!

If you access the Asana project from your web browser, and copy the Asana ID from the web address, you can paste that into the custom tab in the search field in Zapier. If the project doesn’t automatically populate, you’ll want to click “Use [Asana ID]” in the dropdown menu. In the first photo I posted above, it shows in blue “Use 1201885455572590.”

Once you choose that ID by clicking on it, click away from that field and you should be able to continue on setting up your Zap.