Best answer

Zapier isn't receiving data that exists in Person and Date fields from Notion

  • 10 June 2024
  • 8 replies
  • 32 views

Hi all! I’m trying to set up a new zap, to use Notion records in another app. I’ve got everything set up and working except that there are two fields in my Notion database that are showing as “no data” in the Zapier pull. One is a “Person” field, and one is a “Date” field. 

I don’t get any errors, the zap just shows “no data” where Notion is showing data. I don’t think those are property types that are excluded from sync-ing (from what I can see). Anyone have any pro tips for getting “Person” and “Data” data to flow freely from Notion into Zapier?

Thank you!

icon

Best answer by Troy Tessalone 10 June 2024, 23:12

View original

8 replies

Userlevel 7
Badge +14

Hi @saralobko 

Issue may be related to the field types being used.

 

I can't see all fields in my Zap

Not all Notion property types are supported in Zapier. The following property types are not supported:
  • Files and media
  • Formulas
  • Relations
  • Rollups
  • Status
These property types will not appear in your triggers or actions.

Thanks, yes I checked that. The fields are People and Date property types, and are not any of the listed property types that are not supported.

Userlevel 7
Badge +14

@saralobko 

Are you using a Zap trigger example that has those fields populated with values?

Yes, the Zap trigger example has both fields populated with values. Troubleshooting, I also confirmed by checking the “Transfer Data” feature that no data is being pulled in for either of those two fields (at all, with 100+ existing records). I also tried normalizing the date field using Formatter in case that was the issue with the date field, but there is no data being pulled into Zapier from that field to normalize.

Userlevel 7
Badge +14

@saralobko 

Try turning the Zap ON and testing live to see if those fields populated with data, then check your Zap Runs history details to see the DATA OUT for the trigger step: https://zapier.com/app/history/

Troy, that was helpful. I’m not concerned about the People field at this point, but am trying to get the date field working. In the Zap Run history, I can see the following DATA OUT for the trigger step (shown below).

DATA OUT for the trigger step

We don’t use date ranges in that field -- we just enter the date due (which gets stored by default in Notion in Scheduled Launch/start). That value isn’t being passed through in Zapier. (I’m not able to add a “sub-field” using Zapier (e.g. there isn’t a way I can see to specify that Zapier should pull from Scheduled Launch/start).

With that, this looks like a Notion issue, not a Zapier issue, so I’ll come back and post an update once I get it figured out.

 

DATA IN on the action step
DATA OUT on the action step

 

 
Userlevel 7
Badge +14

@saralobko 

Try this tip:

 

That did it, Troy -- thank you!

Reply