Best answer

Zapier is not capturing/reading multi select pick list value correctly

  • 19 January 2023
  • 3 replies
  • 145 views

I have zap running successfully for  quite sometime, I have recently updated to new Salesforce connecting app provided by Zap. Since then Zap is not reading the Multi Select picklist values correctly. Before this used to be separated by semicolon but now it looks like its separating for both semicolon and comma. 

  

Its processing multiple values without comma but with comma its treating as separate value and this failing the zap. 

Before this was able to capture all details as below but now its no longer working 

 

icon

Best answer by Troy Tessalone 19 January 2023, 05:53

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +14

@SalesforceSuppor 

Good question.

In general, commas are used to separate arrays, which is how this field’s data is being interpreted when there are commas present.

If you can I’d recommend changing the Salesforce internal value to remove commas from the options in the field to avoid this.

@Troy Tessalone Thank you for your response and recommendation, I am Hoping their is way to for this as it was working before with comma and not sure what stopped.

Userlevel 7
Badge +14

@SalesforceSuppor 

You can try opening a ticket with Zapier Support for further troubleshooting: https://zapier.com/app/get-help