Best answer

Zapier can’t find my Asana Project

  • 25 April 2022
  • 6 replies

Hi I am trying to build and automation and the Asana project I need is not loading in Zapier, I have read and also wrote in all of the forum question regarding this topic and try out everything mention (Load more button, ID project...) and nothing. 

Out of desperation, tried the same automation in (a Zapier alternative) and it does not have problem finding the project, 

I have other automations in Zapier and do not want to start from scratch in another platform. Can someone please help me understand the problem?





Best answer by rachael.silvano 26 April 2022, 15:22

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 5
Badge +7

Hi there @Damar - I have a few tips below that helped me get set up my first time with Asana projects- it does require a custom ID but it should be pretty straightforward. 

Step 1- in the Asana set up, you’ll want to toggle to “custom” value: 


Step 2- once there, you’ll want to grab the URL of your project in Asana. One error I ran into which may have caused you trouble as well, is you have to click *beyond* the team and into an actual project. The URL should look something like this: 


Go ahead and take anything after the /0/ and before the /[list] section and drop that in Custom- this is what will pull your project for you in a Zap. 


Let me know if this helps! I know I ran into the same speedbumps my first go-around, and I’m happy to continue troubleshooting in you run into any issues at all. 



Hi Rachel, thanks for your reply,

That is actually what I been doing 

In the custom section is not working, but in the project section it works with other projects ID but not with the one I want, it does not matter how many times I click on Load more.



Userlevel 5
Badge +7

@Damar ugh, sorry to hear. 


I have one suggestion, but after trying this I suggest you head over to Support, they are able to dive a bit deeper into what’s going on. Here is a handy link: -also, this may have just been a premature printscreen, but in your first image you were in the Project tab, not the Custom tab. That may have been what you were running into? 


My suggestion is just seeing what happens if you navigate to Custom, enter the custom ID and then moving into the “test trigger” section. When I enter an ID, I don’t always see an option to select, I just enter the ID and move into test. 


Hope this helps, but if not, I bet Support will have a speedy solution they can help you with as well :) 


HI Rachel Thanks for the quick reply,

Yes I tried in the project section since it worked for other projects

when I paste the ID in the Custom section it does not stays there, so when I go into test it brings me back to the project since it does not allow me to test until it recognize the project.


I will try the link you send me and see if I can find further help




Userlevel 5
Badge +7

Sounds good- sorry we couldn’t source an easy win for you, but please do come back and let us know if you need any help navigating support and resolving this Asana issue. -Rachael

Userlevel 7
Badge +9

Hey @Damar just wanted to follow up here! Were you ever able to get this sorted out and select your project? Let us know!