Best answer

Zapier bot can't post to Slack with posting permissions

  • 16 November 2022
  • 5 replies

Hello everyone


I’ve configured a Zapier integration with slack, triggered by new data in an google spreadsheet using the “Send Channel Message in Slack” action.

If I configure in the slack channel “Settings” > “Posting permissions” > “You, and specific people” > Then I add the Zapier app, messages are no longer reaching slack. I’m not sure why this is the case as it was working before that. Since I’m adding the Zapier app to the channel permission I’d expect to be receiving the messages.


Some other things

  • Send as bot is set to Yes in Zapier
  • The user in the action is mine which has admin permissions for that slack channel


Could you help me troubleshoot why messages are not sent to slack? Thanks in advance


Best answer by victorslackquestions 17 November 2022, 12:51

View original

5 replies

Userlevel 7
Badge +14

Hi @victorslackquestions 

Good question.

Help articles for using Slack in Zaps:


Are you trying to use a Private Channel?


Admin/owner permissions - User needs to be a Slack "owner" in addition to being an admin

Hello Troy, not quite. This is a public channel in the organization.

Additionally, I am indeed able to change permissions in the channel. The problem is that after doing it, the Zapier integration can’t send messages to slack

Userlevel 7
Badge +14


Try reconnecting your Slack Zap app here:

Thanks Troy. In the end I tried removing the Zapier integration from the channel, then implementing the permissions and finally readding the app to the channel and it worked.