Best answer

Zap won't pull optional questions from Eventbrite?

  • 16 February 2023
  • 22 replies
  • 571 views

Userlevel 1

Hi,

I connected my Eventbrite event to Airtable to collect attendee data with the “New Attendee Registered” trigger, and it only partially works.

The Eventbrite event has an order form all registrants have to fill out and I want to collect all of this data to Airtable. The trouble is, only the answers to the required questions in the form get pulled when the Zap is live, even though the trigger has detected the optional ones as well when testing and they are mapped correctly.

Eventbrite seems to ask required/obligatory questions first, then the trigger activates, the answers get transferred, and only then does Eventbrite take me to a second page where the optional questions get asked. This second batch of answers of course never makes it into Airtable.

 

Is there any way to fix this?

Thanks!

icon

Best answer by ken.a 17 July 2023, 08:54

View original

22 replies

Userlevel 7
Badge +14

Hi @7theNeven 

Good question.

The issue is likely due to the way the 2 step form is configured as you’ve experienced.

You can try opening a ticket with Zapier Support to see if they can offer any guidance: https://zapier.com/app/get-help

Userlevel 7
Badge +9

Hey there, @7theNeven!

I wanted to pop back in and mention I can see you were able to open a ticket with my teammates in support, which is amazing. They did have a clarifying question that was sent on the 15th:

...could you let me know which fields seem to be missing in the Zap? If you could share screenshots of examples of this, that would be helpful as well!

We’d recommend continuing to troubleshoot with my friends in support but please keep us in the loop with any solutions ya’ll are able to find! 🙂

Userlevel 1

Hey there, @7theNeven!

I wanted to pop back in and mention I can see you were able to open a ticket with my teammates in support, which is amazing. They did have a clarifying question that was sent on the 15th:

...could you let me know which fields seem to be missing in the Zap? If you could share screenshots of examples of this, that would be helpful as well!

We’d recommend continuing to troubleshoot with my friends in support but please keep us in the loop with any solutions ya’ll are able to find! 🙂

Hey, I’ve found a solution! There’s an important distinction in Eventbrite between collecting information from “buyers” and “attendees”. For the Zap to work, the former has to be chosen, otherwise the optional questions get separated and the problem originally described pops up.

Thanks

Userlevel 1

Hi @7theNeven

 

We experienced this issue fairly recently, as well. Not sure when the change occurred but we no longer capture the optional questions from the trigger, only the required ones. 

If I understand your solution correctly, in the event setup on the Order Form options, to have optional and required questions answered at the same time, we must set “Collect information from” to “Buyer only”, not “Each attendee”?

Thanks for your help!

Userlevel 1

Hello @dthtb!

Yes! That’s exactly it.

Userlevel 1

This is actually bigger problem than what’s being reported here, and the context needs clarification. Edit: I solved it by the end.

Eventbrite shows required questions in order to complete registration on both desktop and mobile browsers, then it shows not required questions after registration, which means a huge drop-off in response rate.

Eventbrite actually does show all questions in advance of registration when transacting via their mobile app, but that’s a minority of users.

The problem we’re seeing, since our most important question is not required (it's not applicable to too many of our attendees so it can’t be required, or, if we make it required, too many responses will be garbage), is that we are only getting custom question data sent to Zaps for only about 10% of the responses.

I do not know if that’s because the only ones we’re seeing are purchased via mobile app or if it’s just intermittently working, but I’d bet it’s the former.

We do have our events set to collect custom questions from Each Attendee. I’ll try changing it but I doubt that’s the issue here, since most our ticket sales are single tickets and that would already be only the buyer entering data.

I know there’s data we’re missing from analyzing event reports and seeing all the custom question responses not collected by Zaps.

More than “collect from buyer vs each attendee setting” being the culprit, it makes more sense that the data is sending after the initial registration, so the custom question data doesn’t have a chance to be captured when the trigger activates. Even asking the Zap to delay 5 minutes doesn’t help because once the trigger data goes, it doesn’t revisit it - that attendee is no longer classified as “new” when the optional custom question data arrives.

So - and I’m solving my own problem here by writing this all out, lol - the solution is simply to make the custom questions required when you want their data in Zaps.

I could just make the first of the multi-selects in my question be a “nothing now” option for everyone to which this isn’t applicable. It will cause a drop in responses from those who just want to check it to move on vs read the choices but hey, better than me wrestling with data reports and manual importing, and the trade-off of having it appear up front vs optional after registration is probably better in the end anyway.

Thanks for coming to my TED Talk! 🤣

Userlevel 7
Badge +6

Hi @luckylou,

I appreciate you sharing your insights and thought process about the issue you were facing with Eventbrite. It seems like you've analyzed the situation thoroughly and even come up with a solution along the way!

It's always interesting to see how members tackle and overcome obstacles. If you have any more questions or need further assistance, feel free to ask. We’re here to help! 😊

Hi @ken.a

May have missed a response to this issue, is there a fix planned from Zapier to correctly transfer non-required questions from Eventbrite to other apps? We are using ON24 and this is a challenge for us as half of our Eventbrite questions are not required.

Thanks for your assistance.

Userlevel 7
Badge +6

Hi friends, 

I did some digging into this, and it seems like the “New Attendee Registered in Eventbrite” isn’t able to return non-required questions at the moment. We do have a feature request to return non-required/conditional sub-question answers in “New Attendee” trigger. I have added @dthtb @luckylou @7theNeven, and @MBenninger to the feature request. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track interest in this feature being implemented
  • Allows us to notify you via email if this feature becomes available in the future

While I don't have an ETA on when this feature might be implemented, we will notify you via email if it is!

Hopefully, this helps! 😊

Userlevel 1

This is actually bigger problem than what’s being reported here, and the context needs clarification. Edit: I solved it by the end.

Eventbrite shows required questions in order to complete registration on both desktop and mobile browsers, then it shows not required questions after registration, which means a huge drop-off in response rate.

Eventbrite actually does show all questions in advance of registration when transacting via their mobile app, but that’s a minority of users.

The problem we’re seeing, since our most important question is not required (it's not applicable to too many of our attendees so it can’t be required, or, if we make it required, too many responses will be garbage), is that we are only getting custom question data sent to Zaps for only about 10% of the responses.

I do not know if that’s because the only ones we’re seeing are purchased via mobile app or if it’s just intermittently working, but I’d bet it’s the former.

We do have our events set to collect custom questions from Each Attendee. I’ll try changing it but I doubt that’s the issue here, since most our ticket sales are single tickets and that would already be only the buyer entering data.

I know there’s data we’re missing from analyzing event reports and seeing all the custom question responses not collected by Zaps.

More than “collect from buyer vs each attendee setting” being the culprit, it makes more sense that the data is sending after the initial registration, so the custom question data doesn’t have a chance to be captured when the trigger activates. Even asking the Zap to delay 5 minutes doesn’t help because once the trigger data goes, it doesn’t revisit it - that attendee is no longer classified as “new” when the optional custom question data arrives.

So - and I’m solving my own problem here by writing this all out, lol - the solution is simply to make the custom questions required when you want their data in Zaps.

I could just make the first of the multi-selects in my question be a “nothing now” option for everyone to which this isn’t applicable. It will cause a drop in responses from those who just want to check it to move on vs read the choices but hey, better than me wrestling with data reports and manual importing, and the trade-off of having it appear up front vs optional after registration is probably better in the end anyway.

Thanks for coming to my TED Talk! 🤣

Hey @luckylou

A sort-of-but-not-great workaround for capturing the optional questions we came up with was a second zap that triggers when a registrant is checked in at our event. If they answered the optionals after registration, their answers are still stored on their profile so we were able to grab the data then. 

Again, this is less than ideal as it requires 2 interactions, making sure to check them in at the event(we use the EB app on tablets/phones), and maintaining 2 zaps just to capture what was already given. This of course doesn’t work if they don’t show up or someone neglects to check them in.

@ken.a says a fix might be coming(thanks!) but until then this is what we’ve got. Hope that helps a little.

Userlevel 1

Thanks - I just changed my optional question to required and what’s essentially a “Not Applicable” option as the first choice since we have plenty of people to whom the question does not apply in any way.

Bonus is now my opt-ins are massively up since the prompt is now before completing registration and it’s required.

It will still be nice to get the optional questions Zapped someday, as I can’t make every field required but it sure helps to get the data when attendees respond.

Userlevel 1

@ken.a Is there any update on when this might be available? This seems to be a very important missing feature. Without this, the integration is sort of pointless as I will have to manually go in and update values. 

Userlevel 7
Badge +6

Hi there @sammyknapp,

I did a quick check on the feature request, and it looks like there are no updates yet. In the meantime, I have added you as another interested member to the feature request. While we can’t provide an exact timeframe on the feature’s implementation. We will keep you in the loop via email once there is.

Please note, the duration for feature implementation varies based on its complexity, user demand, and the overall scope. So, the timeframe can differ.

I appreciate your patience and understanding.

@ken.a please add me as a follower to the feature request too, this is a very important issue for our workflow

@dthtb or anyone else, have you tried to use a second zap, triggering on ‘Updated Attendee’ to move the optional questions? I wondered if answering optional questions would trigger that zap, so you could grab the data well before attendee check-in.

Userlevel 7
Badge +6

Hi there @trybalstaffer,

I have added you as another interested member to the open feature request. We will keep you in the loop via email once the feature has been implemented.

Thank you!

Hello- this is impacting my company as well! Custom required questions, now appearing on a second delayed page of eventbrite registration, are not pulling in the zap. 
 

would appreciate being added to the list to be notified and request a solution. 
 

have any effective work arounds been found in the interim?? Using the check in feature if not an option 

 

 

Userlevel 7
Badge +6

Hi @BVM,

I have added your vote to the open feature request. We will let you know via email once the feature has been implemented.

I appreciate your patience and understanding.

Hiya,

Please add us to the list. 

We are finding inconsistencies in the New Attendee Registration trigger - First Name, Last Name, Email and Phone (standard EB registratiaon fields) as well as custom questions which are required on the EB form are passing through inconsitenty. Some Zaps come through successfully, while others are failing with 'info requested’, i.e., data not captured in the trigger. This is true regardless of whether we set the EB order form to either Ticket Buyer or Each Attendee. 

We have used the New Attendee Registration trigger for many years now with no issue. The functionality stopped working consistently last week. Zapier support has advised there is no explanation or resolution so far. 

Thank you. 

 

Userlevel 7
Badge +6

Hi there @Ironfish,

Thanks for bringing this to our attention.

I have added you to the feature request. We will keep you in the loop via email once the feature has been implemented.

Additionally, regarding your query about other runs with “Info Requested” data. I did some digging into this, and it seems like this is related to an experiment that Eventbrite is currently running, where users can fill out a form _after_ buying a ticket.

Since we can't predict when the attendee will provide the desired information, we suggest implementing a two-Zap workflow like the following:

Zap 1:

  1. Trigger: New Attendee
  2. Do the stuff (record the incomplete data wherever you need it, so you know there's a new attendee as soon as possible)

Zap 2:

  1. Trigger: Updated Attendee
  2. Filter: only continue if data does not contain "Info Requested"
  3. Update the data from Zap 1

Hopefully, this helps!

Hi friends, 

I did some digging into this, and it seems like the “New Attendee Registered in Eventbrite” isn’t able to return non-required questions at the moment. We do have a feature request to return non-required/conditional sub-question answers in “New Attendee” trigger. I have added @dthtb @luckylou @7theNeven, and @MBenninger to the feature request. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track interest in this feature being implemented
  • Allows us to notify you via email if this feature becomes available in the future

While I don't have an ETA on when this feature might be implemented, we will notify you via email if it is!

Hopefully, this helps! 😊

Add me to this feature request.  Essentially Zapier is broken for me and doesnt do as I need. 

Userlevel 7
Badge +6

Hi there @wtruong33,

I have added you to the feature request. We will keep you posted via email once the feature has been implemented.

I appreciate your patience and understanding.

Reply