Question

Zap trigger is worked well, But Webflow CMS is not updated.

  • 22 May 2023
  • 5 replies
  • 102 views

I am reaching out to seek your assistance with an integration issue that I am currently facing between Docsend, Zapier Storage, and Webflow. While the Zapier trigger seems to be functioning properly, I have encountered a problem where the expected behavior of increasing the value number on the live website is not being realised. Despite thorough checks and configurations, I have been unable to resolve this issue on my own.

The idea is to increase the “download number” on each product, every time someone click on the download button.

 

 

Any ideas?

Cheers

 

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +11

Hi @Rafael Martins, welcome to the Community! 🙂

Am I right in thinking that you’re using a Zap with the New Space Download (Docsend) trigger to run when someone clicks the download button, and using the Update Item (Webflow) action to update the “download number” field for the product?

If so, is the issue that it’s not updating the correct product? Or is more that the value is not updated?

To help give us a better idea on what might be causing the download number to not be updated correctly here, could you please share a screenshot of the settings and fields that have been selected on the set up of the Webflow action in the Zap? Don’t forget to remove/hide any private information (like names, emails etc.) from the screenshots first.

Thanks, looking forward to your response here!

Hi @Sam

I just noticed that the trigger is actually working fine.
Does it take some time for the numbers to update after someone clicks on the button?
 

Userlevel 7
Badge +8

Hey there @Rafael Martins jumping in to see if I can help!

Can you please clarify which trigger and action you are using? From there I can double check whether the trigger is instant or runs on a schedule! 

@SamB @chanelle 

Thanks for getting back to me.

Here’s the integration I’m trying to create:

1.DocSend
New Visit in Docsend

2.Zapier
Increment Value in Storage by Zapier

3.WebFlow
Update Live Item in WebFlow

The idea is to create a Zap that triggers the following action:
Every time someone clicks on the download button in one of my products, it triggers the Number of Downloads counter (Increment the value by 1). Everything seems to be working fine, but the actual number of downloads are always incorrect. Let’s say the number is “10” and instead of increasing to “11” after someone clicks on the button, it jumps to a random number like “74”.

I believe the “Number of Downloads” (Screenshot attached) should reflect what I have on my WebFlow CMS but at the moment it’s not. I’ve created a Zap for each product, and for some reason the information seems to be somehow linked to each other causing the issue. 


There’s a video on Youtube that gives you a better understanding of what I’m sort of trying to achieve.
Here’s the link:


Does that makes sense? Let me me know if you need further info from me.

Cheers,

Rafael


 

Userlevel 7
Badge +11

Thanks for following up here with those details, @Rafael Martins!
 

Does it take some time for the numbers to update after someone clicks on the button?


The New Space Download trigger is an instant trigger so (unless there’s some delay on DocSend’s end) we should receive the new download events sent over from DocSend without any delays. 
 

Everything seems to be working fine, but the actual number of downloads are always incorrect. Let’s say the number is “10” and instead of increasing to “11” after someone clicks on the button, it jumps to a random number like “74”.


If it’s not increasing the download number correctly could it be that the key is incorrect? For example are the storage key’s unique to each product or are downloads for every products being added to the same storage key? 

Could you please share a screenshot showing what’s currently selected for the Increment Value action in the Zap? We can’t look into your Zaps so that’ll also help us to better see whether there’s anything in the set up that might be causing that to happen. Please remember to remove or hide any private information from any screenshots first.

Looking forward to your reply!