Best answer

Zap test works, but on live site the squarespace form fields are pulled differently

  • 25 September 2023
  • 14 replies

I am trying to distribute a Squarespace form submission to multiple email addresses. I’ve set up my Zap and tested it … it works great with the internal test. Here is a screenshot of the resulting email:


However, when I go to the live Squarespace site and try using the form, Zapier seems to be including the field labels as well as the field data (But for only some of the fields), making the email look confusing for my recipients. See screenshot:


I tried creating a fresh, new Zap, and got the exact same result.


Any ideas?


Best answer by Freaky Stylie 26 September 2023, 03:07

View original

14 replies

Userlevel 7
Badge +14

Hi @Freaky Stylie 

Good question.

To help us have more context, please post detailed screenshots with how your Zap steps are configured.

Thanks for your help @Troy Tessalone . Please see screen shots below.



Userlevel 7
Badge +14

@Freaky Stylie 

Did you test the Squarespace form to then pull in the real data samples to configure the Zap?

How to change the Zap trigger data:

Check your Zap Runs to see the DATA IN/OUT for each Zap step to help you troubleshoot:

@Troy Tessalone Please bear with me, I’m very new to this, so I don’t quite follow your questions and direction.


Did you test the Squarespace form to then pull in the real data samples to configure the Zap?

I don’t know the answer to this question. What I did was:

  1. create the Squarespace form
  2. connect it to Zapier in the Squarespace form configuration
  3. Create my Zap in Zapier

I checked the link on changing trigger data, but I don’t really understand what I’m looking at. Here’s a screenshot of my trigger test data. There is only the one dataset to view, and clicking “Find new records” doesn’t do anything. 


Userlevel 7
Badge +14

@Freaky Stylie 

Try submitting the actual SS form.

Then change the Zap trigger data to pull in the form data you just submitted. (use the Find new records button)

Then reconfigure the Zap.


This looks like dummy data that I don’t think you filled out.


@Troy Tessalone I wasn’t sure what you meant by 

Try submitting the actual SS form.

If you meant submit the squarespace form with Zapier connected and running the Zap, that’s what I’ve been doing, and resulted in the original screenshot I sent. Here it is again:

Since I wasn’t sure what you meant, I also tried disconnecting Zapier, submitting the form, then reconnecting Zapier. 

Neither of these actions changes the trigger data. 

Apologies for being so confused over here.




Userlevel 7
Badge +14

@Freaky Stylie 

When configuring the Zap in the Zap editor, you should be able to pull thru your real data submitted from the SS form.

That will help you configure the Zap correctly.

If you see your test data, then make sure you’ve selected that on the left in the screenshot below before configuring the Zap actions.


@Troy Tessalone I’m sorry, but could you please really spell this out for me with some specific steps I need to take? I don’t understand what you are telling me to do.

No matter how many times I submit the SS form (I just tried again, no new records appear in the test section shown here: )

The best that I seem to be able to do is hit the pencil icon and manually create a new record like this:

But I don’t understand where that gets me.

Userlevel 7
Badge +14

@Freaky Stylie

Have you reviewed the available help articles for using SS in Zaps?


It can be a bit finicky to connect SS forms to their Zaps.

Perhaps try duplicating the Zaps.

  1. Basically you need to do a live test on the SS form.
  2. Then pull thru that real data example in the Zap trigger.
  3. Use that to configure your Zap steps.
  4. Turn Zap ON.
  5. Test again.
  6. Check Zap Runs.
  7. Verify results.
Userlevel 7
Badge +14

@Freaky Stylie 

If you still need help, consider hiring a Certified Zapier Expert.


@Troy Tessalone Thanks for providing those links to the guides and troubleshooting. I did follow them, and linked SS with Zapier no problem. The troubleshooting does not cover my specific issue. 

I want to make sure we are talking about the same issue here: my Zap is definitely connected to the SS form, and it is definitely pulling the data from the form.

The issue is that in the email that the Zap sends, the data is displayed funny. I’ll use the following example data:

  • name “Bob Singular”
  • CPSO Number: 999
  • Cell or Pager number: 123 456 7890
  • Case Description: Silly case goes here

The Subject line should look like this:

NVC referral from: Bob Singular

But instead it looks like this: 

NVC referral from: {First=Bob, Last=Singular}

In the body of the email the data should look like this:

Referred by: Bob Singular
CPSO Number: 999
Cell or Pager number: 123 456 7890
Case Description: Silly case goes here

But instead it looks like this:

Referred by: {First=Bob, Last=Singular}
CPSO Number: 999
Cell or Pager number: 123 456 7890
Case Description: Silly case goes here


So, for some reason the Zap is including the Squarespace field name as well as the field data in the email. I would like Zapier to only use the field data, not the field label.

Have I clearly described the problem?

Userlevel 7
Badge +14

@Freaky Stylie 

I’m clear on the issue.

Can you show screenshots of the DATA OUT from the Zap trigger step in your Zap Runs:

@Troy Tessalone thank you so much for putting my on the right track with this last investigation.


 Here’s the screenshot you requested that clarified everything for me: 


I see from the outgoing data that SS is sending “Name” as a single chunk of data. {First=X, Last=Y} and Zapier is just dealing with that. Squarespace is misleading: the form shows two different fields for “First Name” and “Last Name”, but I just discovered that when building the form, SS only has a single field for “Name”, which it later displays as two fields.

I resolved my issue by NOT using the Squarespace “Name” field, and creating my own text fields called “First Name” and “Last Name” and using them in the Zap.

Thank you so much for your patience and help with this issue.

Userlevel 7
Badge +11

Great work, @Freaky Stylie! 🙌

Glad to see Troy was able to point you towards a solution. And thanks so much for circling back in here to share details of how you solved this, it’s most appreciated! 🤗

Seems like you’ve got everything figured out here but if you run into further issues or need any help again in future please do reach back out to the Community - we’re always here and happy to assist!