Question

Zap not working after deactivated User. Error Message - This step maps fields that don’t seem to be available

  • 3 November 2023
  • 1 reply
  • 28 views

Hi 

We have a zap which sends invoices from Salesforce to an external accounting software (Xero) and then back into Salesforce. This has been working fine previously, however this month the previous Salesforce User account Zapier was linked to was deactivated and invoicing hasnt worked as a result. 

 

To fix, I tried reactivated the previous user. This didnt work so instead i changed all reference to the previous user in Zapier and also changed the outbound message in Salesforce so that it corresponded with the new running user. This again didnt work. 

 

Looking into the Zap, I can see that there are error messages for steps 2 - 5 due to This step maps fields that don’t seem to be available. There have however been no changes in the fields used in Xero or Salesforce. Looking into the actions on the steps, I can see that there are error messages with either “1. Send an outbound message in Salesforce” or “4. Create a Sales Invoice in Xero”. “2. Find Contact in Xero” and “3. Find Record in Salesforce both seem to map correctly”. 

 

Any thoughts on what the issue might be would be really appreciated! Thanks,


1 reply

Userlevel 7
Badge +14

Hi @xanderops 

Good question.

Check your Salesforce Zap app connection here: https://zapier.com/app/connections

Otherwise, we would need to see screenshots of the errors shown in the Zap steps.

Reply