Question

Zap isn't triggering for new leads in Facebook Lead Ads with shared use is "restricted"

  • 14 November 2022
  • 3 replies
  • 68 views

Userlevel 1

Hello everyone,

I’m having a issue when a form have the field “shared use” as “restricted” and the zap don’t trigger the new leads.

When “shared use” is “open” everything works fine.

How can i solve this?

Thanks you!!!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 6
Badge +8

Hey there!

Is that something you can change to be open on that form?

I’m not familiar with that interface in your screenshot, but it sounds like maybe you’re having some permissions issues. Can you follow the steps in this help document (you have to scroll to the bottom to see the content) to see if you can get permission to that form?

Let us know how that goes!

Userlevel 1

Hello!

Thanks for you fast answer.

I check all the permissions in the facebook business but it seems to be right. If i test all the forms with the facebbok tool (https://developers.facebook.com/tools/lead-ads-testing/) everything is OK! All the forms Zaps in Zapier (Open or Restricted all of them works fine). The problem is with restricted forms in real leads and the leads i send through the instant forms:

 

The leads that come from forms with "Sharing" or “Shared use” as "Restricted" do not reach zapier, but if I edit the Zap and press "Test trigger" the lead appears, but it is not activating the Zap! (The Zap is On always) I have to press it manually to get the lead. In Transfer data option I can also get it. I don’t know why it is not activating the Zap..

 

 

Thanks you!

Userlevel 7
Badge +9

Hey there @MarketingComunica!

I did some digging and noticed you were doing some troubleshooting with my friends in support. That’s actually perfect in this case, since they needed to pull some of the logs from your zap.

I’d recommend continuing the process with them and hopefully ya’ll are able to get to the bottom of this! 🙂