Best answer

Zap doesnt trigger even though timestamp of "Last modified time" column changes

  • 22 September 2023
  • 3 replies


I have an Airtable base of customers who are attending an even we organize. I’d like to sync their email addresses (from two columns in Airtable) to a list in Zoho campaings (similar to Mailchimp).

I have added a “Last modified time” column in my Airtable base, which updates whenever the content of the two email address columns are modified. This works without any errors in Airtable.

I have set up the zap, triggering on changes to the “Last modified time” column, and syncing the email address to Zoho campaings. In Zapier, the set up seems to be correct and when testing, the data is synced as supposed to.

However, after the zap is published, and I try to modify the content of the columns with the email addresses, nothing happens. I see no activity in the zap history. Any ideas why? The zaps should trigger quite immediately?


I appreciate any suggestions to help me out. Thanks!


Best answer by Troy Tessalone 22 September 2023, 17:47

View original

3 replies

Userlevel 7
Badge +14

Hi @Odd Harald 

Good question.

Airtable Zap triggers are scheduled, meaning those can take from 1-15 minutes to fire depending on your Zapier plan.


Thanks for the quick answer, Troy! That solved my issue!

Userlevel 7
Badge +6

That’s great news @Odd Harald! Glad to hear the issue is now solved, thanks to Troy’s assistance!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help!