Question

Zakeke New Order trigger not firing after republish, even in test mode

  • 4 October 2023
  • 4 replies
  • 52 views

I am using a standard New Order Item in Zakeke action that gets triggered whenever my Zakeke-enabled Shopify store generates an order. When I first established the zap, the orders were triggering correctly. and the zap ran. At some point, I unpublished my product on Zakeke, made some changes to both my zap and my Zakeke product, and then republished the Zakeke product. Now new order triggers are not being seen by the zap. What comes after the New Order in Zakeke action is immaterial because the zap never makes it that far.


I tried reconnecting the zap to my Zakeke account. I tried resetting the Client Id and Secret key. Nothing works. When I test the connection, I can see orders from before the unpublish/republish sequence. But the new orders don’t show up for testing the zap. So they don’t trigger the zap AND Zapier can’t even see them in testing mode.


4 replies

Userlevel 7
Badge +14

Hi @OtisJ 

Good question.

To help us have more context, can you post screenshots with how your Zap trigger step is configured?

I may be missing the subtleties of your question. Beyond the plug and play functionality, how do I show the trigger configuration?

 

 

 

 

Here’s the update. I explored the APIs for getting orders from Zakeke and ws able to make a standard order downloading call, My understanding is that Zapier polls the Zakeke site and when it is passed a list of orders, figures out which of these orders is new. And that is how it triggers the zap. 

 

Well, from what I get from the API, either Zapier is ignoring the new orders, the API works for me but not Zapier, or Zapier is not actually executing the API call.

I’ll keep digging. 

Userlevel 7
Badge +11

Hi there @OtisJ! 🙂

Your understanding is correct here. The Zap would regularly poll Zakeke, looking for new orders and trigger the Zap for each new order it finds. If the Zap was working correctly before the changes to the product then it could be that something to do with the changes on that side of things is what caused a disconnect between Zakeke and Zapier. 

Though, I’m wondering if when you reconnected the Zakeke account with the new details it automatically connected with previously cached details. To test that theory can you try reconnecting the account within either a different web browser or a new private browsing window/tab? That should ensure that the Zap definitely connects with the new details and with any luck get the Zap triggering on new orders again.

Keen to help get to the bottom of this so please do let us know how that goes!

Reply