Best answer

YouTube “The request cannot be completed because you have exceeded your quota” error

Userlevel 3

Hi all --

I have a Zap that gets triggered when a new video appears in a playlist. Over the past 10 days I’ve received a couple of failure notification emails from Zapier that indicate

Error Message:

32 YouTube: Trigger partner failure: The app returned "The request cannot be completed because you have exceeded your <a href="/youtube/v3/getting-started#quota">quota</a>.".


Any suggestions on how to stop this from happening?

FWIW, the only other post on this that I’ve found is this one:

which refers you to a Google API docs, and through them, to the Google API console, which doesn’t actually show who and how quota units are being used up. Is there a way to find out how many quota units are being use by a Zap, or if not, influence the triggering somehow? My Zap only needs to run once a day, but right now the only relevant YouTube trigger options seem to be to select “When a video shows up in a playlist”.

Any suggestions would be appreciated -- thanks in advance!


Best answer by christina.d 18 August 2022, 00:25

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

374 replies

Userlevel 7
Badge +14

Hi @Ar3m3f 

Might be best to open a ticket with Zapier Support for more guidance:

Userlevel 1

Same Issue. Let's talk here.

Same issue. Yes let’s talk here as Ambler mentioned.

Userlevel 7
Badge +11

Hey everyone! :)

@Ar3m3f, I can see that you’ve reached out to our Support team about this and have been added to the bug report for this issue here.

@360Creators, I’ve added you to the list of affected users on that same bug report so we’ll be in touch once it’s been sorted out.

@Ambler, as mentioned in the other thread I’ve added you to the bug report for this.  

We’ll be in touch once we have any further news on this! 

Moderator Edit: Removed suggestion of turning the Zap off and on again as this appears to now be resulting in a “There was a problem activating your Zap” error.

Hi, all! Getting the same issue here. Turned the Zap off and back on. @SamB, would appreciate it if you could add me to the bug report so I can get the updates. Thanks!

hello, same here. Please add me to the bug report and keep me posted. thank you! @SamB 

Userlevel 7
Badge +9

Thanks for reaching out, @zhengzither and @monicacne.

I’ve got you both added to that report as impacted users. We’ll be in touch via email with updates as soon as we have them!


We are getting the same error. Please add me to the affected users list @christina.d 

I tried turning the Zaps off and then on, but still no resolution.


I have also been getting this error since the past 2 weeks. Can you please add me to the affected users list @meena ?

Userlevel 1

I turned it off and on again, but there was a problem again. Mail bomb.

Userlevel 7
Badge +9

I appreciate you both reaching out to let us know, @Pracbee and @meena!

I’ve got you both added as impacted users that report. As soon as there’s a fix in place we’ll keep you and the other impacted users in this thread updated via email. 

I’m sorry to hear you’re still getting that error, @Ambler. While we don’t have any other workarounds to recommend at the moment, we’ll be sure to update the thread if we come across one!

I as well have been having the same issues

Same issue for me if I can be added to list of affected users. Tried to authenticate new apps with different connections as well (one of which has never been used for API).  Also strangely having it with other automation services, so my guess is a larger YouTube/Google API issue? 

Userlevel 1


I’m affected by this as well. I’d appreciate it if you added me to the list @christina.d 

Thanks and cheers

Same issue for me.

I tried these workaround. But no one didn’t work.

  • off the zap and on
  • re-create connection account setting

Would you please add me to the list of affected users? @christina.d 

Userlevel 1

This is because the zapier is limited to the YouTube api quota. The quota needs to be expanded. There's nothing we can do.

Userlevel 7
Badge +11

Hey there @Mr Design Wolf, @JordanB, @dod and @r3it! I’ve added you all to the list of affected users as well.

I’m so sorry that workaround didn’t work as hoped. We’ll be sure to email you all as soon as this has been sorted.

Userlevel 1

Thank you @SamB 

Hi @SamB @christina.d I am affected by this bug as well. Would appreciate it if you can add my to the bug report as well. Thanks!

Userlevel 1

Hey, @SamB @christina.d I’m also being affected by this, please keep me updated!

Hi… please add me to the list as well. Same problem.

Userlevel 7
Badge +9

Thanks for letting us know @Hilario@joelheath24, and @Justice4me!

I’ve got all of you added to the list of impacted users. We’ll be in touch as soon as we know more. 

Howdy! Add a +1 data point to impacted users. Thank so much for looking into this!

@christina.d I have turned the zaps off, when I go to turn on I get that error as well. Please add me to the list.

Thank you.

Userlevel 1

@christina.d I also am seeing the error.