Best answer

Xero raw API request - failing "Please select an organization to perform this step on."

Userlevel 1


Hoping someone can assist. I’m trying to use the API Request (Beta) in Xero action to create an HTTP request to perform an action that’s not covered by the standard Zapier Xero connector.

However I just can’t get past the first stage of authentication, I just keep getting the error message:

In the other Xero actions, in the Action step there is an Organization field where I can select which Xero company I want to use and it feels like this is missing in the API Request (beta) action.

Organization field in other Xero actions
Organization field missing in the API Request (Beta) action

Has anyone else managed to successfully use the API Request (Beta) action?


Best answer by jamestc989 21 May 2024, 10:55

View original

14 replies

Userlevel 1

I should have added that I have tried adding the Xero-Tenant-Id to the request headers but it makes no difference. Possibly in the background this is what Zapier does in translating the Organisation selected in the UI to the HTTP request that it fires off to Xero but I can’t tell.


Userlevel 3
Badge +3

I think there was another discussion here with a similar issue:


@JamesWalsh What is the API call that you are trying to make that is not covered by Zapier? I am a Xero power user so want to see if there are alternative solutions.

Userlevel 1

Hi @fiona819 
Thanks for that link, I must admit I didn’t find that while I was searching, it does look like exactly the same issue as I’m facing and didn’t look as though and answer was found.
I do think it’s just that the ‘Organization’ field is missing from the Action step in the Zap, but I don’t know how we get round that.

What I was looking to do was to update the line items on invoices and bills, we basically split our sales and purchase invoices between tracking categories so that we can report on them. The invoices are created in our front office system which posts them to Xero, but it doesn’t post with the splits just a single line item, so at the moment someone has to manually update each invoice and it’s a lot of work. I was looking to create a Zap that’s triggered when a new draft invoice is created and then goes in and updates the invoice with the line item splits automatically.
So I was planning to use the Xero API Invoices endpoint with a POST method to update the lines. But until I get the authentication sorted I’m going nowhere with Zapier.
Happy to hear any suggestions you have for another way to achieve this


Userlevel 3
Badge +3

Hi James, just to clarify:

“we basically split our sales and purchase invoices between tracking categories” 

  1. Front office system → Xero - draft bill (purchase) → one line item that you want to split into different line items and the tracking category matches each line item
  1. Front office system → Xero - draft invoice (sales) → one line item that you want to split into different line items and the tracking category matches each line item

Question1 - is the above correct? Or you are just looking to solve for (B)?

Question 2 - Is the tracking category “Account” or you have custom fields? Do you need that automatically mapped or you let Xero/manually do it?

Sample bill (this one just has standard “Account”) 

Sample invoice (this one has a custom “Project” added)


Userlevel 1

Hi @fiona819 
Yes we’re looking to achieve both A and B. Generally each transaction has both a sale and (self bill) purchase invoice. The account would be the same on all line items, but the tracking categories would provide the split. We use two tracking categories and I’d envisage having a mapping table in Excel/Sharepoint which we’d build some steps in the Zap to go off and find the split for us.

Userlevel 3
Badge +3

Hi @JamesWalsh got it, thanks

  1. What is the current step 1 in your flow?
  2. Is it one transaction split into one sale invoice and one purchase invoice (bill) by tracking category?
  3. Would you have a sample of how 1 transaction comes in so I can understand how to do the split? (Or you can direct message me as well if the data is sensitive, or a sample will work just fine) 
Userlevel 1

EXACTLY the same issue. We’ve got a lot of backend systems running off of Xero API requests which can’t be done through the default Actions - even a simple lookup of Invoice/Bill by the ID is not possible out of the box.

This fault began occuring yesterday and I’ve tried every work around. Custom Actions no longer work for Xero either because of the Organization apparently missing. I’ve tried hard coding the Org ID into the Header, setting it dynamically and also just using Custom Request and setting it through there - nothing is working.

Raised a ticket yesterday and suspiciously within about 2 hours support said it was an issue their end and it was fixed and to retry. Nothing changed and still not fixed. No reply since this time yesterday, so much for “Premium” support via the Teams level plan.


Userlevel 1

Hi @jamestc989 

Ah good to know that it’s not just me then, and interesting that it was working prior to yesterday, I was just unlucky.

OK well fingers crossed that the support team get it sorted.


I am having the exact same issue but with getting a Xero Contact by ContactID.


Thought that it would be natively support but it isn’t so I had to create a custom action but I am stuck on this error. I also tried entering the Xero Org ID in the headers and it doesn’t work. I put into feedback on the custom action page.

Userlevel 1

Hi @jamestc989 

Wondered if you’d heard back from support on this issue yet? I’m still getting a failure when I try to test the connection.

Userlevel 1

Bad news unfortunately. This is the reply from Zapier. They are really good at encouraging loyal customers of many years to want to look at alternatives - breaking functionality like this with no notice and no intention to rollback or urgently fix is appalling.

Anyhow, to get around this, I rebuilt through Custom Integrations and I’ve got my steps working. 

Zapier reply:


I understand that this ongoing issue with Custom Actions and Xero has been causing significant disruptions for your operations, and it’s clear the impact it has had on your ability to pay out suppliers in a timely manner is far from ideal.
After consulting with our development team on this again, it appears that the underlying problem is tied to a known bug within the current Custom Actions setup. I wish I had better news here, but the resolution for this bug is pending the rollout of a new version of Custom Actions, which is slated for release in June 2024. This update is expected to address the issue.
I understand how this timeline might be disappointing and the constraints it imposes on your workflows, and wish I had better news in this case. 



Userlevel 1

OK thanks @jamestc989 for the update. Pretty poor from Zapier not to roll back/fix an issue that they created.
I’ll have to try myself with Custom Integration.

The fact that this is taking Zapier so long to fix is Shameful. It's why really big companies scoff when people recommend they use Zapier. 


Anyhow, to get around this, I rebuilt through Custom Integrations and I’ve got my steps working. 

@jamestc989 by “I rebuilt through Custom Integrations and I’ve got my steps working.” do you mean you used generic Zapier webhooks action to connect to Xero and execute your needed APIs. Xero authentication is a bear. Can you share how you set up your actions to authenticate to Xero?