WPForms - Authentication failed: The app returned "403".

  • 28 April 2023
  • 4 replies

This post was split from topic: 


I am having this issue.  I have tried private windows, made sure there is not trailing spaces.  I have 40+ WPForms Apps.  This one is giving me a hard time.

We hit an error adding your new account

authentication failed: The app returned "403".

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information

4 replies

Userlevel 6
Badge +6

Hi there @JoeZap,

Welcome to the Community! 🎉

I have created a new topic for your reply, as the error you're encountering is different from the OP.

Upon digging into the 403 error in WPForms, it appears that a security plugin can cause this issue on your WordPress site. In this case, I suggest disabling all security plugins on your website and attempting to reauthenticate via Zapier.

If you are able to authenticate successfully, you can try enabling each plugin one at a time to isolate the problematic one.

Please let me know if this gets you pointed in the right direction! 😊

I’m having the same problem. Wondering if anyone found a solution for this. Tried disabling all plugins, tried turning off cloud flare temporarily but no luck. Still seeing the following:

We hit an error adding your new account

authentication failed: The app returned "403".

On the wordpress side WPforms still shows Zapier as connected. Tried activating / deactivating but nothing. 
Would appreciate any help / ideas. 

Userlevel 6
Badge +6

Hi @EllaR,

I did some digging into this, and it appears that the 403 error you're experiencing could be due to your connection being blocked. In this case, you'll need to get in touch with Cloudflare or the website host, especially if they're the ones who set up the Cloudflare connection. They will be able to assist you in allowing the request to go through.

Hopefully, this points you to the right direction.

Thanks a million for your reply (I just wish I saw it few days ago haha).
For the benefit of future readers:
Indeed, the problem was with Cloudflare - disabling it temporarily (and waiting for few minutes for it to propagate) allowed me to establish the zapier-wpforms connection. Once connection is authenticated I enabled cloud flare again and all is good in the world.