Best answer

WordPress error: Authentication failed: WordPress ran into an issue; error code 401

  • 19 January 2023
  • 5 replies
  • 955 views

Hi all! 

When I try to connect my WP account to Zapier I get the following error:
 

After this error I get an email in my inbox with the following content with a link in it:

The request was flagged as suspicious, and we need verification that you attempted to log in to allow it to proceed. This verification link will be valid for 15 minutes from the time it was sent. If you did not attempt this login, please change your password immediately.

I click on the link to verify that it is me, but sadly, the screen with the error above doesn't change at all. So clicking on the verification link doesn't resolve anything. I also tried this by using an incognito window, but that didn't work either. 

Hopefully someone can help me out with this. I saw similar issues like this in this community, but they didn't provide any solutions. Thank you in advance!

icon

Best answer by jesse 20 January 2023, 21:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +12

Hi @Sabrina!

Does your Wordpress account always send you a verification email when you log in? Do you have Two Factor Authentication (2FA) enabled? If so that might the cause of the issue as the Zapier WordPress integration doesn’t currently support 2FA. If that’s the case, let us know and we can add you to a feature request to support 2FA, which means that we can let you know when we have an updated. 

If you don’t have 2FA set up on your WordPress account, let us know so we can keep working on this with you :)

Thanks!

Hi @Danvers,

Thank you for your fast reply! That is the weird part of it, according to my WP account my 2FA is not active, but I do get these verification emails when I try to connect WP to Zapier. For other connection I didnt get them, so this is only the issues when using Zapier. So far, every time I try to connect WP with Zapier I get the verification email as well as the error. Hopefully this information can help.

 

Userlevel 7
Badge +9

@Sabrina thanks for the context! I just did some quick browsing on the internet and came across this article that includes a few things to try to resolve this error: https://kinsta.com/knowledgebase/401-error/

I haven’t tried these steps before so keep that in mind when exploring, but these do appear to be legitimate troubleshooting steps and might be something to consider trying. 

Keep us posted with how you make out - we’d love to know other ways to resolve something like this and be able to share it with other members!

Hi Jesse,

Thank you for your help, I deactivated some plugins and I think I am getting a step closer. I have the following error now. 

authentication failed: request to https://playtowork.n/wp-json/zapier/v1/token failed, reason: getaddrinfo ENOTFOUND domainexample.nl

domainexample should be or own host but for safety reasons I left it out ;).

So how can I solve this issue?

Got it! Typed in the wrong url. But I deactivated the firewall/protection plugins and that should do the work! After the connection has been made, I actived them again and it stills works! Thank you very much.