Question

WordPress error: authentication failed: "Moved Permanently" response received. HTTP status: "301" on https://capharnaum.net.

  • 10 January 2024
  • 4 replies
  • 191 views

Every time I try to connect my account, I get the following error message.
This is very inconvenient :( Could you please get back to me as soon as possible?

 

We hit an error adding your new account

authentication failed: "Moved Permanently" response received. HTTP status: "301" on https://capharnaum.net.

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information

4 replies

Userlevel 7
Badge +14

Hi @Capharnaum 

Have you reviewed these help articles for using WordPress in Zaps?

https://zapier.com/apps/wordpress/help

This article doesn't answer my problem at all :(

The problem is that I can't even connect my wordpress account to Zapier to trigger an event. It just hangs.

Userlevel 7
Badge +14

@Capharnaum 

Did you try these suggestions:

Error: 500 Internal Server Error or other trouble connecting

In order to connect to WordPress, you must have XML-RPC functionality turned on. This is turned on by default in WordPress 3.5+. If you're having issues connecting, go to Settings > Writing > Remote Publishing and check the checkbox.

You may also receive this error if your WordPress installation is secured and not publicly available. Unfortunately, the installation must be publicly accessible to work with Zapier.

Also, we're unable to provide IPs to allowlist as our IPs are not static - they rotate because we use AWS. If you'd like, you should be able to allowlist a block of IPs from AWS to make this work. You would just need to make sure the list you're allowing is the us-east-1 IP range.

AWS provides a list of their IP address ranges at https://ip-ranges.amazonaws.com/ip-ranges.json. You can read more about how to use those IPs here.

Additionally, Zapier's calls will always include the header User-Agent: Zapier, so this may be an alternative when allowing a whole range of IPs isn't feasible.

Error: (403) Forbidden

Jetpack Protect (official WordPress module) will occasionally block some AWS IPs you can either allowlist the IP listed in the error, disable Protect altogether, or if try and allowlist all AWS us-east-1 IPs. You can read more about how to use those IPs here.

Once you do that, try reconnecting your WordPress account to see if this resolves the issue.

If you have a firewall enabled please double-check that it allows Zapier to connect as well.

Error: XML-RPC server accepts POST requests only

This error could mean that you're using the wrong Base URL in the login screen. If you're using http: try using https:. If you're using www.example.com try using it example.com.

If you continue to get this error, then it's likely because the XML-RPC is being blocked on the WordPress site. It's most likely being blocked by a plugin, the hosting provider, or a security setting. To fix, try disabling a your plugins one and a time, then try reconnecting to WordPress account to see if you can isolate the problem plugin.

If not, it might be a back-end change that needs to be made by your hosting provider or website developer. We recommend reaching out to them and asking them to update the XML-RPC settings for you. You can send them this link for more information: https://codex.wordpress.org/XML-RPC_Support

If your provider/developer wants to allowlist access to us, you can let them know that we use Amazon's AWS products for our server infrastructure, so they'll need to allowlist their IP list from the us-east-1 region. You can find that range list here: https://ip-ranges.amazonaws.com/ip-ranges.json . You can read more about how to use those IPs here.

Reply