Best answer

Why Is Zapier So Slow?

  • 27 January 2023
  • 7 replies
  • 314 views

Userlevel 1

so I wrote in here over the summer how when zapier made a bunch of changes to the interface, that it was much slower...and honestly I haven’t seen much improvement since.

 

Just trying to click to open a zap and it will get stuck loading, to the point where I’ll have to refresh the page and reclick the link a couple of times.

 

When actually in the editor, just opening up a basic filter will get stuck loading to the point where I also need to refresh the page, and even then, the problem persists, or ill have to sit there for 15-30 seconds waiting for the data in the filter to finish loading and populate

 

Basic things in zapier that used to take a minute to do, are now taking 3-4x as long, as things just continuously get stuck loading.

 

this is the only website i experience this on. I know it’s not my internet speed, my download speed is 633.4, and im running on a brand new macbook pro m1

icon

Best answer by Rachael S 30 January 2023, 23:14

View original

7 replies

Userlevel 7
Badge +14

Hi @Chris Lombardi 

What browser are you using? (Maybe try a different browser.)

Make sure there aren’t any browser extensions that could be impacting Zapier.

Make sure to share this feedback thru the proper channels by opening a ticket with Zapier Support for it to be logged.

Userlevel 5
Badge +7

Hey @Chris Lombardi I hear you, and the slowness is something we’re heard from other folks. I know it can feel a little surface-y to say “we’re letting the right people know about it” but we did send your feedback directly to the product team. I hope it speeds up on your end soon, and to Troy’s point it’s sometimes can help to give new browser a try just to see.

 

But again, we see you and your feedback is valuable to us, we’re gonna make sure it gets read by the right folks and hope you get a better experience soon. 

 

Thanks- Rachael

Userlevel 1

I am using chrome, but i tried it with Safari as well and the slowness persists. Butjust like @Rachael S said, they’ve heard it from other folks as well.

 

In a lot of the marketing groups im in, a lot of people are having the same problems. It’s been like this since this new interface came out back in june-july...it’s been over half a year...i understand saying we’re fixing it, but when it’s been this long, it just feels like this aint getting fixed, and this is just how the platform is going to be.

Userlevel 5
Badge +7

Hey there @Chris Lombardi, I understand your frustration as someone who uses our tool often as well. I will say, and I’m with our whole team now as I write this (we’re at our company retreat in fact), I do think the fixes we’re deploying over the coming weeks are going to make the experience of the editor better. I hope you have some patience and grace in the interim, but I trust that the folks we have working on the problem are going to make it better, I know it’s a very top level priority. 

 

Thanks for coming and voicing your thoughts, and we hope things resolve quickly. 

 

Best -Rachael

Userlevel 1

6 weeks later later update - yes there are some new features, but the platform is still as slow as it was before. 😐

I m facing this issue too, not sure why my Zapier would run before it fetches the data from my Salesforce.. Basically what happened was that I successfully integrates Google row 1 to Salesforce field but for the next few integrations, if done too fast it will overwrite the previous integration because the Find Record node haven’t detected the changes yet. What’s weird is that it’s showing up nicely in my Salesforce but not in the Get Record..

It’s truly unfortunate. I come to this thread having taking 20 min trying to get a zap to load and it simply won’t. I’ve been using Zapier since 2016 and have evangelized the service to many partners in higher education. What used to take 30 seconds now takes forever. It is so frustrating. 

Reply