Best answer

Whenever I add a specific assignee to a ClickUp task, the Zap doesn’t work

  • 18 November 2022
  • 6 replies

Hi everyone!

Basically what I wanted is to set up an automatic message that will be sent in slack whenever an assignee is added to the task. And so far, it not working for me. What I have done so far is:

  1. I used task changes in ClickUP
  2. set up “what changed?” to Assignee Added
  3. Added the Assignee name

One thing to note is that when I’m testing the zap, I am receiving the notifications, but when I go and test it real time via Clickup, it’s suddenly not working. Also other choices like change in status, added tags, priorities, even assignee added (no specific Assignee added) works, which I find weird!

To put it simply, whenever I add a specific assignee, the zap doesn’t work.


Any ideas how to fix or even set it up properly?




Best answer by christina.d 22 December 2022, 03:01

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +8

Hi @adminfreelancer 


When you set a specific assignee in Clickup action, this means that only when this person is added to the task it will trigger. Is this what you are aiming for? Also this might be if the assignee field is empty and this assignee is the first to be added, you should test that as well

@MohSwellam Yes, however in my case, I already did add the assignee person in clickup action and tested it real time as well, meaning I already added the person I set on the clickup action, to the task I created in clickup app but the zap is not triggering for some reason.

“Also this might be if the assignee field is empty and this assignee is the first to be added, you should test that as well” - already tried this as well and it’s still not working :(

Userlevel 7
Badge +8

Hi @adminfreelancer 


In such case and since other options are triggering, I would suggestion opening a ticket with , they would be able to look behind the scenes and see what is happening. 

Did this ever get resolved? I appear to be having the exact same problem, and although I’ve made a workaround, a proper solution would be greatly appreciated.  

Userlevel 7
Badge +9

Hi friends! I wanted to share what appeared to be the solution from OP’s support ticket:

Looks like the trigger is setup properly which is great. But it also looks like there's just one field in the action step that's not filled out. In your zap the field for List is required, but there isn't anything mapped out to it just yet:

You'll just need to select the list to where the task needs to be created. From there, you should be able to turn on the Zap

If it turned out to be something else that got ya on track, @adminfreelancer definitely let us know! Always happy to update the answer. 🤗

Userlevel 7
Badge +9

Hi @npot - so sorry to hear you’re running into this as well. 😔

I just shared what may have been the solution in the comment above. If that field is already filled out for you, I’d recommend either opening a new topic here in the community or opening a ticket with my friends in support to dig into this a bit more with you. 🙂

Thanks for asking in the community!