Question

When new events are created in Microsoft Outlook, tasks are not being created in Todoist

  • 31 January 2023
  • 7 replies
  • 125 views

Hi, I crated my first zap that creates a task in Todoist when I create a calendar event in Microsoft outlook. I tested the zap and it worked nut when I published and tried an actual event it doesn't seem to work? Do I need to do anything else? thanks


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @Twisty76 

Good question.

All of the Outlook Zap triggers are scheduled, which can take from 1-15 minutes to trigger depending on your Zapier plan.

Check your Zap Runs to see if the Zap eventually fired: https://zapier.com/app/history/

 

Thanks Troy, appreciate the reply. 

Unfortunately there doesent seem to be anything in my Zap history

 

Userlevel 7
Badge +14

@Twisty76 

Might be best to open a ticket with Zapier Support for further assistance troubleshooting your Zap: https://zapier.com/app/get-help

Thanks Troy

Userlevel 7
Badge +9

Hey there, @Twisty76! I can see you were able to open a ticket with my teammates in support, which is great.

They had some initial troubleshooting steps they recommended which included checking:

  1. The event in the screenshot was created while the Zap was on?
  2. Does the calendar belong to xxxx@gmail.com?
  3. The event in the screenshot is in "Calendar"? https://cdn.zappy.app/fc927e8745a3fb28ded14823d961d4ef.png
  4. Can you create a new event for tomorrow at any time and see if it triggers the Zap?

I know you mentioned at the moment, this account only has read permissions - which I wonder if that could be problem?

Typically for Zapier to work with Microsoft products an administrator will need to grant access to connect to third parties - Managing user consent to apps in Microsoft 365

If you’re able to get the permissions changed, I’d also reconnect with Outlook, and try running the zap live again. If you’r still running into this after that I’d recommend continuing the process with my friends in the ticket. This way they can dig a bit further with you!

Keep us posted on your success! 🙂

Thanks Christine, I have tried all above and still doesent seem to work. The only think that seemed odd was when I tried to look at the following “ Microsoft 365 admin center, go to the Settings > Org settings > Services page, and then select User consent to apps.”

It seemed to prompt me to sign into a work or school account even though I am already signed into my personal account? Screenshot attached with email blocked out

 

 

Userlevel 7
Badge +11

Thanks for letting us know @Twisty76!

Hope you don’t mind me popping in for Christina here. 🙂

I’ve had that happen to me before where I’ve been signed in but was asked to sign in again. At any rate, if the connected Microsoft account has the correct permissions it should be able to see the events.

That said, the connected account would need to have/be on one of the following supported plans:

  • an Office 365 subscription
  • a Microsoft live.com account with Outlook
  • or individual purchase of Microsoft Exchange Online subscriptions (not self hosted)


It looks like you’re attempting to sign in with a Gmail email address so I just wanted to check whether the account you’re connecting to is on one of the supported plans?

If you’re on a supported plan and are still having issues getting the Zap to trigger for new events I’d recommend replying back to our Support team so they can continue investigating this with you. They’re able to access the logs for your Zaps will be able to troubleshoot this further. Please do keep us updated on whether you’re able to get this resolved!