Best answer

We hit an error adding your new account with LearnDash

  • 28 October 2022
  • 6 replies

Userlevel 1



I keep on receiving an error every time I connect my Membership Site through using LearnDash


We hit an error adding your new account

authentication failed: The app returned "If you are the site owner (or you manage this site), please whitelist your IP or if you think this block is an error please open a support ticket and make sure to include the block details (displayed ...". If you are the site owner (or you manage this site), please whitelist your IP or if you think this block is an error please open a support ticket and make sure to include the block details (displayed in the box below), so we can assist you in troubleshooting the issue.


I can’t figure out where I can resolve that.


I tried whitelisting my IP to my hosting site but nothing resolved yet.


Best answer by RALaBarge 22 November 2022, 16:46

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +11


I see you’ve reached out to our Support team. That’s probably the best course of action, since they can access more than we can here in the Community (Zaps, history, logs, etc).

I did do a bit of digging and I found a note from the LearnDash team suggesting that users reach out to them as well (if you haven’t already):

When you end up resolving this, we’d love to hear about it, since that could help other users who are experiencing this issue. Hope it gets resolved for you soon!

Userlevel 1

Hi @nicksimard 


I’ve reached out LearnDash Support and they said Error is originating from Zapier and gave me a link of a related topic but it’s not really what it is.


Hope you can help me with this.


Userlevel 7
Badge +11


So sorry for the runaround, and the back and forth. That’s not the experience we want our users to have! I checked our Support team’s response and it looks like they’d also suggested that you contact LearnDash.

A few months ago, someone from LearnDash left the following comment in regards to a similar issue:

This issue usually comes from conflict with a caching plugin.

Can you please ask the customer to whitelist our endpoint URL query at or disable the caching plugin to see if the issue goes away?

If the issue persists, can you please ask the customer to contact our support directly at


Maybe try what they suggested, and if it doesn’t work it’s honestly best to work with our Support team. They can open up a bug report to bring some attention to it.

The LearnDash team are the ones who created and maintain the Zapier integration, and the error message we’re seeing is coming from LearnDash. Maybe the person you reached wasn’t aware of that?

I really hope you’re able to get this figured out!

Userlevel 1

Hi @nicksimard. Thank you so much for your response. I already contacted Learndash regarding this issue and here’s the response I got


Thanks for this.

I was able to replicate the issue after I first attempted to reconnect your LearnDash site to your Zapier account. I then went to isolate the issue by connecting my demo LearnDash site to your Zapier account and it worked perfectly:

I then isolated it further by connecting the Zapier for WordPress plugin (which I temporarily installed in your site) and that still got the 403/access denied error:

I can't see any security plugin installed except for Jetpack but it doesn't have the security feature enabled as well. I'm thinking this has to do with how your website is securely hosted. I suggest reaching out to your hosting provider to check for any security settings or software in place that could potentially block Zapier from communicating with your website.

PS: I've already uninstalled the Zapier for WordPress plugin and removed my LearnDash demo site connection in your Zapier account.



and when I tried to contact GoDaddy,  they asked me to “confirm once how they are connecting via IP address or some thing else”

Userlevel 4
Badge +7

Hey there @GWPMAK, with regards to what GoDaddy is asking, Zapier does not connect to your server from a single IP address.  The only thing that would be consistent is the “User-Agent” header we are sending always containing the value Zapier.

Zapier uses the Amazon Web Services cloud services to host our application, and our IP could be one of millions which is randomly assigned from Amazon whenever we need to send a request out to the internet.

Finally with regards to authentication actions in our service, Zapier never validates the credentials you send us to login.  We just send those as you supplied them to the 3rd party we are connecting to.  When authentication issues occur, the only thing Zapier usually knows is that our request with your authentication credentials was rejected.  We don’t know why unless the service who rejected our request shares that bit of data.   The logs that exist on the LearnDash server would have more info as to exactly why our request is being rejected.

Hopefully this adds some context while you continue to look into your server to see if you can find any additional information for troubleshooting! 

Userlevel 1

Thank you both for your help. I already resolved the issue. Blessings to everyone :D


Summary to resolve Zapier Authentication Issue

  • Logged in to GoDaddy and went to Website Security Firewall Settings.
  • Found logs of blocked request from Zapier.
  • Clicked on the log and it present an option to Allowed IP address
  • Clicked on each log that I found and allowed them all
  • Now it's working.