Question

Utilities Formatter not separating text by comma separator.

  • 14 June 2023
  • 1 reply
  • 81 views

I have an Eventbrite integration that is pulling in order data which, if the order was for more than one ticket, shows each answer multiple times for each ticket. So, ticket quantity I get 1,1,1,1 instead of 4. I’m using Zapier formatters to break these down and reference them later on.

Here are my settings:

App - Formatter

Event - Utilities

Transform - Line-item to text

Input - my data line which, if the answer was ABC and the person bought 3 tickets would show ABC, ABC, ABC

Separator - blank - default is “,”

 

and it looks / returns something like this:

 

 

But then I get to the final category - custom question answers. We have two required custom checkout questions. The first is a selection of text from a drop down and the second is fopen for fillable text.

 

For whatever reason, the only way Eventbrite gives me those answers in Zapier (via either the new attendee or new order triggers) is combined as one item - and then copied x the # of tickets purchased.

 

The raw data that comes out of Eventbrite looks like this:

 

 

When I run the same settings I get the following output:

 

I’m guessing that because it is actually two answers back to back and then repeated that somehow it’s not reading the same - but I have no idea how to fix it!

 

I did try to do Event: text and Action: Split hoping I could split them by a “,” but I get the same result.

 

 


1 reply

Userlevel 7
Badge +14

Hi @ALTSO 

Good question.

It’s due to the data structure. (array with objects OR object with arrays)

Honestly the best way to handle the nested data will be with more advanced approaches using Code and possibly Webhooks.

The concept is to get the RAW JSON data structure to then parse/prep.

If you need help, consider hiring a Certified Zapier Expert: https://zapier.com/experts/automation-ace

Reply