Best answer

Upwork error: Zapier could not connect to your account.

  • 13 April 2023
  • 9 replies


I’m getting the following error when trying to connect my Upwork account:

Oh, foo.

Zapier could not connect to your account.

I’ve tried disconnecting and connecting again several times, but I always get the same error.



Best answer by Danvers 13 April 2023, 11:39

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +12

Hi @Siddesh, welcome to the Community!

I’m sorry you’re having trouble connecting your Upwork account to Zapier. It looks like there’s currently a bug affecting the Upwork integration where some users run into this type of error when trying to connect. 

I’ve added you as an affected user on this bug. This lets the team know how many people are affected by it, and we’ll update this post and send you an email when we have an update. Thanks!


@Danvers Thank you for the update,..
What is the expected timeframe for the system to run smoothly??
What can I do to overcome this problem? is it something related to user id.. will it work for another user id from my organization?

Userlevel 7
Badge +6

Hi @Siddesh,

I apologize for the inconvenience, but we don't have an estimated time for when the bug will be fixed. However, we will notify you via email as soon as the fix is released.

Regrettably, there are no current workarounds available for this issue.

We appreciate your patience and understanding while we work towards a solution.

Thank you! 😊

Same issue


Userlevel 7
Badge +6

Hi @connorld,

I have added you to the list of affected users. As soon as a fix is available, we will notify you via email.

Thanks! 😊

I am having the same issue - my Upwork app is not connecting

Userlevel 7
Badge +6

Hey there @Bateman Collective,

I also added you the list of affected users. As as soon as we have a fix ready, we'll shoot you an email to keep you in the loop!

Thanks! 😊

Based on this issue this is an error that has been occurring for over a year with no resolution.  When will this be prioritized as this is supposedly a “Premium” product?

After doing troubleshooting, it appears that the app isn’t handling the returned code correctly.  If you capture all the requests & redirects, a code is successfully returned, so the App isn’t processing it correctly.

Userlevel 3
Badge +4

Hi @trex 

We can't update users on precise bug statuses or estimated timeframes until the issue is resolved. Many factors are at play when addressing a bug, so predicting when it will be fixed is challenging.

I can share that the bug has been logged, the requisite teams have been informed, and we're working on resolving it as quickly as possible. We will let you know by email as soon as there are any updates to the bug and it is resolved.

In the meantime, I'm doing everything I can to pass on feedback like this to help ensure that the impact of these issues is clearly understood.