Best answer

Update Checkbox (multiple options) in HubSpot from Zoom Registration Value

  • 19 December 2022
  • 12 replies
  • 292 views

Hello,

We have a Zap setup that takes data from a simple Zoom registration and creates (or updates) a contact in HubSpot and adds them to a static list. Everything works well except this piece.

In Hubspot, one field is a multi-select checkbox. In the Zoom registration, that corresponding field is a drop down so it will only have one value. In the Zap, if I map the Hubspot checkbox field to the Zoom drop-down field, I get “Property values were not valid validationMessages:”.

I only have two options (ABC Hospital and DEF Hospital) and confirmed that they are the same in HubSpot and the Zoom drop down. If I choose the values from HubSpot, those values will go in.

However I need the custom value that i get from the Zoom registration.

But when I do that, get this error message

 

I’m at a loss as to what to do. After reading forum posts on here and over at HubSpot I’ve tried adding semicolons before and after the custom field, I tried a Lookup Table but those were all unsuccessful. Does someone have an example of something they can share or give me a hint as to how HubSpot expects the data?

icon

Best answer by bturc 6 January 2023, 16:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

12 replies

Userlevel 7
Badge +12

@bturc Any chance there are any leading or trailing white spaces/extra spaces in the value from Zoom? It would be hard to see in the mappings but maybe you could see it in the data output on the trigger step

Thanks for getting back! I checked the values in Zoom and there are no leading or trailing spaces there. When the zap errored out, I checked the Data Out tab and it looks like nothing is being added to that field just in case in was Zoom doing something extra.

 

Userlevel 7
Badge +9

Hey @bturc sorry for the trouble here! In this particular instance, I might recommend contacting our support team. They’ll be able to look at the logs returning this error message and likely have some additional detail to offer. You can contact them here: https://zapier.com/app/get-help

Keep us posted on how things turn out - we want to make sure everything gets sorted out for you!

Thanks Jesse! I’ll contact support and post updates here. Thanks, -Brian

Userlevel 7
Badge +8

Hi @bturc 

 

As a workaround, you can use Paths by Zapier to hardcode those options (since you only have 2). 
 

Path 1 would be if Zoom has ABC Hospital, you choose the ABC Hospital in Hubspot

 

Path 2 would be the other option.

 

hope this workaround helps.

Userlevel 7
Badge +9

Hey there, @bturc! I wanted to pop in and see how you were getting along with this?

Looks like @MohSwellam had a great recommendation and I can see you were able to reach our friends in support - which is perfect. 

Keep us posted! 🙂

Thank you for the recommendation @MohSwellam and follow-up @christina.d!

I upgraded and tried the Path feature but I’m still running into problems. I can’t seem to match on ABC Hospital. If I change the only continue if… arguments to (Text) Contains and then enter ABC then Zapier indicates that my path would continue and I can “hard code” that value in HubSpot via the Create or Update Contact in HubSpot.

However, that doesn’t happen in HubSpot and Zapier is not showing and warnings.

I find it odd that ABC Hospital doesn’t seem match but ABC does...Is there a blank space character that needs to be passed?

Also not sure what seemed to work with me choosing the hard coded value from HubSpot before doesn’t seem to work with the Path feature now.

 

 

Userlevel 7
Badge +11

Hi @bturc!

This is a strange one indeed. I just tested a custom property on a contact in HubSpot and I was able to set a dropdown field to the option I chose when I selected (“hard coded”) it in the Zap.

So, is it the case that you’re not able to set that field at all by selecting it in your Zap then testing that step? It really should be as simple as using Paths or even two separate Zaps with filter steps in each. A Lookup Table should also work, if the value from Zoom is always one of a handful and you’ve got an exact match in your lookup table.

I see a Support ticket from December where one of our support team members responded. Maybe reply to that email and see what they can find for you? This should be a relatively straightforward thing to do. 

Hello @nicksimard! That’s correct - setting the multichoice checkbox in HubSpot to the custom question value from Zoom always errors, even when they are the same value.

I was able to use the Path functionality to get a value into HubSpot except in my real scenario, my multiselect is 72 values so I can’t use the Path because I’m limited by the number of Paths I can have and i had issues matching the value with the string operator. I tried a Lookup table as well but I ran into a problem the same with Path where I had trouble matching the string from Zoom.

contains ABC Hospital -- Did not match

contains “ABC Hospital” -- Did not match

contains ABC -- MATCHED!

contains ABC H -- Did not match

contains “ABC Hospital” -- Did not match 

exactly matches ABC Hospital -- Did not match

exactly matches “ABC Hospital” -- Did not match

 

Some of the hospital names in real life are like:

ABC - Main Street Hospital

ABC - Washington Ave Hospital

 

LOL it seems so straightforward not sure what is going on. Thank you all for the support. I’ll finish my email reply to the support ticket since we’re off break now. Best, -B

Userlevel 7
Badge +11

Hi @bturc!

So, for the Path rules (or filter steps, since they work the same way) if you’re trying to match things like...

  • ABC - Main Street Hospital
  • ABC - Washington Ave Hospital

… then you could add multiple conditions.

  • Contains ABC 
    AND
  • Contains Hospital

Or, if it’s the case that when it contains ABC it will always contain Hospital, then you could just use that first condition of contains ABC.

A lookup table should work, so I would definitely ask our Support team if they can track down what’s causing that error. With 72 hospitals it should just be a matter of setting up value-pairs that have the Zoom value on the left and then the HubSpot value on the right. Getting those correct values appears to be the tricky part here, possibly because of something our logs could help troubleshoot (which Support can access for you).

Please do let us know if you find a solution for this!

Hi All! I got an update from Support last night:

As it turns out, what we're seeing is a known bug where the data we're seeing doesn't actually match the data in the backend, leading to this error.

I’ll update when I get more information from Support but for now, I may just remove that field from my Zap and do a manual HubSpot import from the Zoom registrations to populate the hospital field.

Thank you all! -B

Userlevel 7
Badge +12

Hi @bturc, thanks for letting us know how you got on with the Support Team and I’m sorry that you’ve run into a bug. Fingers crossed the team from HubSpot will be able to look into this for us!