Best answer

Unable to specify the new project name when creating the Frame.io folder from New Project.


Userlevel 1

Hi there. I’m having an issue with using a zap to create a folder in frame.io using the creation of a new project in frame.io as a trigger.

The trigger works fine, but on creating the folder, the Project field wants me to specify a project, and not use the name of the project that has just been created. If I use a custom field to ask it to use the name of the project, it’ll just create the folder inside the project that was used for the test action.

Does anyone have any ideas? I’ve tried everything I can think of and have run out of ideas.

icon

Best answer by Troy Tessalone 8 June 2023, 01:28

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +8

@richrhp Hmm, can you try hitting the refresh fields button and see if it populates? It may simply be because it is a new project. Let me know what the result of this is, happy to come back and assist. 

Userlevel 1

Unfortunately it doesn’t populate with the new project name field. I’ve had to blank out the names of the projects, but here’s what I’m getting:

This is what I can see under the project field. It’st just a list of the pre-existing projects, and nothing linked to the new project trigger from the first step.


I can see the Name or ID fields in the custom list, but this seems to bake in the Name or ID for when the zap is triggered, so creates the folder in the same project as what is tested in the zap instead of the new project that triggered the zap.


I hope that makes sense. Any other ideas?

 

Thanks in advance.

Userlevel 7
Badge +14

Hi @richrhp 

Good question.

Map the ID of the Project from Step 1.

The mapped variables are dynamic.

When the Zap is ON and runs, the mapped variable values will change.

 

 

Userlevel 1

Hi @Troy Tessalone, thanks for the response.

 

I have tried this too, but it seems to save the value of the ID from the test permanently instead of being dynamic as I would expect it to be. I don’t know if this is due to it not appearing in the “Project” list, and so forcing me to select it from the “Custom” list for the Project field. The behaviour is the same when using the Name property too.

For example, I’ve just tested it again, and let’s say the ID from your screenshot is the ID for project 5678, I’ve just created a new project in frame.io and called it 1234. Instead of the folders populating in 1234, they are created in 5678. Here’s my full create folder action:
 

 

Maybe I’ve got something else wrong here?

Userlevel 7
Badge +14

@richrhp 

Try this...

 

Userlevel 1

@Troy Tessalone Amazing! That worked. I’m still pretty new to Zapier but this has been the only one that’s stumped me so far as I don’t think the solution was very obvious given “root” was an option, as that then seems like it should work.

For anyone else that comes across this with the same issue, the name field doesn’t need to be the Name property, you can just set it to whatever you want the folder to be called.

Thanks again Troy  :)