Unable to login in Zapier stuck in login loop.

  • 5 December 2023
  • 3 replies

I am stuck in a Login Cycle. I was in the middle of working on a Zap when it told me all my integration credentials were expired and needed to be renewed. I clicked the button to renew and in the popup it was asking me to re-login to Zapier. I entered my email, then my password and it cycled back to the email again. After three cycles I close the window and I was then kicked out to main login in the main browser tab. Where the same thing is happening. It asks me to login. I enter my email, then my password and it goes right back to asking for email again.

I tried resetting my password after it told me I had tried too many times. Password reset appears to work just fine. When I went to login it is the same behavior as before. I can not login to any part of the system, it just keeps cycling back to asking for email again. 

3 replies

I managed to get past the login, to my Zaps, by pasting in this link -

I can see my list of Zaps, but if I try to edit or create a new Zap, I get kicked out the the login again.


So, not really an answer for you, but you are not alone. 😔

Thanks! If Zapier would give us a way to actually report these things it would be nice LOL They are aware and working on the issue.