Unable to find Upwork room for Asana task tag trigger.

  • 11 March 2024
  • 3 replies

Hi everyone,

I’ve started creating Automations with Zapier for Asana and UpWork but something doesn’t work quite well. 

The automation is triggered when adding a tag to that task and by doing so, it should trigger “Leave Message on a Room” in Upwork. 

The trigger with Asana works correctly, but I am not able to find the room in Upwork I created beforehand. Even if the link to Upwork is apparently correct. Both in Zapier and in Upwork appear that the other service is successfully connected.


Can someone help me with this problem?


3 replies

Userlevel 7
Badge +14

Hi @Joseph_Eight 

Check your Upwork Zap app connection here:


If you know the Room ID, then try setting that via the ‘CUSTOM’ tab.


Hi Troy, thank you very much for your reply. 

I don’t know exactly how to get the Room ID from Upwork. It doesn’t appear to be a way to do it through the user interface. I’ve tried to copy the URL in several forms but none worked.



Userlevel 7
Badge +14


Try using the Upwork Zap app triggers/actions together: