Question

Unable to create SharePoint folder

  • 15 November 2023
  • 5 replies
  • 201 views

I’m trying to create a folder in SharePoint, eventually tied to a Gravity Form submission. However even the most basic hard-coded details aren’t working.  Here’s a ss of the zap:

 

Test results in:

 

 

After doing a little sniffing around, I was pointed towards an article where admin privileges for apps needed to be allowed in Azure, which I’ve done.  I’ve deleted and reconnected the Zapier integration using my account credentials and I’m an admin/owner of the SP site.  Any ideas? Has anyone run into similar issues?


5 replies

Userlevel 7
Badge +14

Hi @PatLFI 

Good question.

Try selecting a Parent Folder.

 

Good idea, I’ve tried that in my troubleshooting too.  Validated the path using the Document Library web part on SP, and keeping it in a top level directory.  We have a folder named “documents” and using Documents (or documents) still gets me access denied.  Using the prefixed “/” as recommended in the tool tip yields a malformed URL error, so the “site” field must be appending an trailing “/” or something.

Userlevel 7
Badge +14

@PatLFI 

Was this the help article you reviewed?

https://help.zapier.com/hc/en-us/articles/16774279432205-How-to-get-started-with-Microsoft-SharePoint-on-Zapier#connect-to-app-on-zapier

 

 

I am experiencing the same issue. I had one Zap using this action, and it was functioning properly.

However, when I tried to create another one for a different site using the same action, it's not working now.

It's not retrieving the subfolder list, and I receive an 'Access Denied' message if I try to proceed without selecting any folders.

 

Userlevel 7
Badge +14

@GCS Operator and @PatLFI 

You can try opening a ticket with Zapier Support: https://zapier.com/app/get-help

Reply