Question

Unable to add my Instagram for Business to Zapier.

  • 16 February 2024
  • 5 replies
  • 70 views

Userlevel 1

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Hello Kind Zapier Support Team!

 

I been now trying in every imagined way to connect My instagram business accounts to zapier and till now, Zapier cannot detetct any of my Instagram for business accounts.

 

What I already Tried:

  -Facebook → Apps and websites  (not solving the problem)

 

 

 - Then I tried it with open the Facebook Business suite and Allow it manually to connect with zapier 

      and this still didn’t solve the Problem. 

I cannot add picture, but it won’t even show in Meta business suite → Integrated apps. section.

 

I believe That the problem is issud by the meta business manager, But ofc i am now here to depend on the Zapier staff and I will hope that They will help me.

 


5 replies

Userlevel 7
Badge +6

Hi @Saed,

Welcome to the Community! 🎉

Before we dig deeper into this, could you please try reconnecting your Instagram for Business account here: https://zapier.com/app/connections/instagram-for-business

After that, please check if it’ll load your Instagram page in the “Instagram Account to Use” field.

Kindly give it a try and let me know how it goes? I'll keep an eye out for your response!

Userlevel 1

Hello, I have the exact same problem

Userlevel 7
Badge +6

Hi @ivan_corr,

The first step to resolve this would be to check all permissions are right for the account, that it's a business account connected, and that you don't have more than 25 Facebook pages connected to the account.

If all of the above is in line, this issue can usually be solved by reconnecting the Instagram account to Zapier (in private browsing).

Hopefully, this helps!

Userlevel 1

I don’t think support is understanding the problem. We CANNOT check the permissions first, because the page isn’t listed in the first place. That’s the problem, zapier opens a pop-up and facebook is asking what pages to let zapier manage, but the IG account isn’t there. I’ve deleted all access, then literally get verified on IG and do it again but it still isn’t listed. Can you help?

Userlevel 7
Badge +11

Hey folks 👋

Just came across this thread and wanted to check in to see how everyone is getting on with this? 

If you’re still having some trouble can you check whether the account you’re attempting to connect is a Business Instagram Account (Creator accounts aren’t supported) and that the connected user for that account is either an Editor or Admin for the page that’s currently missing? 

If that’s the case, then you’ll want to ensure that Zapier has been granted all the necessary permissions in Facebook here: https://www.facebook.com/settings?tab=business_tools&ref=settings

If the correct permissions are already granted and the page still isn’t appearing then you may need to remove Zapier’s existing access and before re-attempting to add the Instagram for Business Account. You can remove it from the list of business integrations on your account. Please note it can take up to 12 hours for this connection to be removed.

Keen to help get this sorted so please do keep us updated on how things are progressing!

Reply