Troubleshooting Xero account connection error in Zapier for invoice generation

  • 29 February 2024
  • 1 reply

I’m unable to connect Zapier to a Xero account. I’ve had connections that have worked before (as has the zap I created).


I’ve recently created a new Xero account and have set up a Zap which finds or creates a in Xero and then generates an invoice in it.


The zap runs through completely until it comes to creating an invoice at which point it generates an error saying:

Please re-connect your Xero account to Zapier on and try again.


I’ve checked that the connection is live (it is - as I say above, the connection works because it is generating new users (or checking existing ones) in Xero from the data it has been passed to it.

To ensure it isn’t a problem my end I have deleted the connection, cleared my cache, tried on different browers to reconnect, deleted the connection off Xero, etc. and restarted from scratch a few times.


If I attempt to reconnect or test the connection it comes up fine.


II know the connection is working because as I say - it is happily generating new contacts and checking the existing ones.

I’ve been in touch with Zapier support for a couple of weeks about this and I’ve been told this is a known problem but there are no workarounds or updates.

Anyone else getting this? I don’t want to have to spend time manually generating invoices!



1 reply

Userlevel 7
Badge +14

Hi @durolitum 

Did you review the help articles for using Xero in Zaps?