Best answer

Troubleshooting- Need Separate Emails from Google Sheet Loop

  • 22 November 2022
  • 4 replies
  • 28 views

Userlevel 1

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Let me set the stage. I have a google sheet filled with info that needs to be emails. One column of the sheet is email addresses. I want a zap that reads each row and makes an email from each row. 

 

I have already done this with google sheet → loop → hubspot tickets. It works great, an individual hubspot ticket for each row.

 

I’ve set up this new zap the exact same way, but I get just one email that is:
to: every address rather than one per email

subject: (all the subjects)

body: Hi (name 1, name 2, name 3...)

 

I don't get why the loop makes individual hubspot tickets as needed, but the same loop can’t make separate emails. Help!

 

Thanks!

 

 

icon

Best answer by Troy Tessalone 22 November 2022, 18:24

View original

4 replies

Userlevel 7
Badge +14

Hi @carnold 

Good question.

Make sure to use the correct Variables from the Looping step that don’t include “Preview”.

 

When you tested the Looping step did it return the expected number of Loop iterations or ONLY 1?

If only 1, then you may have to change to use Looping > Text, instead of Looping > Line Items.

Userlevel 1

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

I don’t have any other choices for the fields I need.

 

When I did the test of the loop, I got this which made it look like it was working. I am looping line items, would changing it to text be the solution?

 

Userlevel 7
Badge +14

@carnold

Looping help article: https://help.zapier.com/hc/en-us/articles/8496106701453#create-a-loop-from-line-items-0-2

Don’t use the preview_loop_values field from the loop test in your Zap. It is for preview purposes only and doesn’t appear in actual Zap runs.

 

You should be using these variables:

 

 

 

Userlevel 1

That did it! Thanks so much for the help.

Reply