Best answer

Troubleshooting GoToWebinar Custom Registration Questions: Character Limits & More

  • 16 December 2022
  • 4 replies

Userlevel 1

Hello. I’m aware that there are currently some bugs that were being worked on with the GoToWebinar app, but it seems like it’s loading my webinars again so I’m hoping those have been fixed. I used the exact same Zap last year to automate registrants from our website using the User Registration plugin in Wordpress to then create a webinar registrant in GoToWebinar. I ran into some issues previously trying to get the test to go through using custom registration questions. It ended up working for me though last year perfectly fine but I’m running into some similar issues trying to get it working now. On the troubleshooting section for GTW it says that it won’t be able to see custom registration questions, it had a similar message last year under troubleshooting, but I was still able to get this to work even using the custom questions.


Is this still a common issue with GoToWebinar or can custom registration questions be used still? If so, are there any character limits to the questions or any other things I can try to troubleshoot this? I saw something about the state name and using Formatter to make sure it’s spelled out but since it worked previously as-is, I didn’t know if I should look into that or not. I’m just looking for some help so I can get this working again. I use this Zap as the user registration flow for our virtual event website and the site really depends on this working properly. Our event is coming up pretty soon and I really need to get this up and running again properly. Any help or suggestions would be greatly appreciated. 


Best answer by chanelle 23 December 2022, 19:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +12

Hi @jtiams!

I’m afraid I don’t have any additional information for you on either of those issues, I’m sorry about that. 

I can see that the issue where users are seeing ‘error 400’, or sometimes that there GoToMeeting account keeps disconnecting from Zapier is still open, meaning that we haven’t confirmed it as resolved. The team are working on it as a high priority. 


Regarding the custom questions, it sounds like you’re hoping to get responses to custom questions using the New Attendee or New Registrant Trigger, is that right? I can see that feature request hasn’t been added to the GoToWebinar integration yet. It’s really interesting that you were able to get the responses to custom questions last year, is there any difference/s between the questions you used last year and this year? Have you tried testing this using the exact same questions as last year? That would tell you if it’s something related to character limits or if it’s that it’s just not working anymore. 


I hope that gets you pointed in the right direction, let us know if you have any other questions!

Userlevel 1

Hi there. Thanks for responding. I am using the same questions as last year and I’m not sure why it’s not working for us this time. We have a few custom questions that we use on the webinar registration form and I have those same questions that I use on our website registration form. I’m going to try setting things up using no custom questions and see if that gets it to go through. 

Userlevel 1

I received an email that said that the bug has been fixed but this is still not working and I’m getting the 400 error when I try to test the Zap. The webinar loads now but it won’t finish the test successfully. I’ve tried creating a new webinar and using each of the different event types, webcast and a standard event. I’ve tried with no custom questions and used only the questions that are standard for GoToWebinar registrations and nothing is working for me at all. All of the questions, even custom ones, still display and allow me to map them out in Zapier but when it gets to the test nothing gets it to go through. I’ve tried multiple different user’s information. I’ve tried just about everything I can to get this working and unfortunately it just doesn’t. Do your other users have better luck using a different app than webhooks to connect to GoToWebinar successfully? Can someone take a look at the Zap setup and see what’s going on? I’m not doing anything differently than what I had set up last year for this Zap and I’m out of troubleshooting options.

Userlevel 7
Badge +8

Hi @jtiams, sorry for all the issues you are encountering. I think this is something worth contacting our excellent support team for. They can take a more in depth look and make sure you’re good to go!