Best answer

Trouble uploading attachments files from Smartsheet to Google Drive

  • 4 August 2023
  • 9 replies

Userlevel 1

Hi @ken.a, I have been trying the suggestions of this thread in order to create the round-a-bout way of getting files attached from a new row on smartsheet, automatically in my GDrive folder.
I am stuck on the 3rd action step.  Any help/insight would be appreciated.
Thank you!


Best answer by ken.a 8 August 2023, 07:33

View original

9 replies

Userlevel 7
Badge +11

Hi @NaNuVS, welcome to the Community!

Hope you don’t mind but I’ve split your question out into it’s own topic as it seems to be specifically around having issues with the Upload File (Google Drive) action. Can you share some further details about where you’re getting stuck on that? 

If you can share a screenshot of the Actions section of the Upload File action to show it’s current set up, that will help us to better see what might need to be tweaked in order to help get those attachments from SmartSheet uploaded to Google Drive. Please remove/hide any private information from the screenshot before sharing (like names, email addresses etc.).

Looking forward to hearing from you on this!

Userlevel 1

Hi @SamB,
Thank you!  I’m actually having issues with the 3rd action step (the 2nd API request) from the original 4 from the thread:

  1. Trigger
  2. API Request (Beta) in Smartsheet
  3. API Request (Beta) in Smartsheet
  4. Upload File in Google Drive

The test run of the first API Request works but not sure what I’m doing wrong for the next one...

Thank you,


Userlevel 7
Badge +6

Hi @NaNuVS,

I’m jumping in to see if I can help!

Looking at the screenshot, it looks like your setup is correct. However, the URL you pasted in the “URL” field might contain some white spaces. Could you please double check if the URL you’ve pasted doesn’t contain a white space?

(view larger)

Please keep us posted! 😊

Userlevel 1

@ken.a, Thank you for catching that!  Issue solved. I appreciate both yours and @SamB help. 
Will this workflow still work with multiple attachments submitted to one row?

Userlevel 7
Badge +6

Hi @NaNuVS,

Awesome! I’m glad that worked!

If you want the Zap to work on multiple attachments you’re going to add a Looping by Zapier step on the 3rd step. Here’s how the setup will look like:

(view larger)


Here’s how the complete step by step setup on how to achieve this:

  1. Trigger: Smartsheet - New Row - First, create a sample data that contains a multiple attachment in the Smartsheet row, and select that as your sample data in the “Test” section of the trigger by clicking on the “Find new records” button.
  2. Action: Smartsheet - API Request (Beta) - Don’t change anything here.
  3. Action: Looping by Zapier - Create Loop From Line Items - We’re going to setup the Looping by Zapier step like this:
    (view larger)
  4. Action: Smartsheet - API Request (Beta) - We’re going to map the created value from the Looping by Zapier step to the “URL” field. Like so:
    (view larger)
  5. Action: Google Drive - Upload File - We’re going to map the “Response Data URL” from the 4th step to the “File” field in the Google Drive step. Like so:
    (view larger)

Hopefully, this helps! 😊

Userlevel 1



Thank you for putting that workflow together step-by-step.  I had to run through and refresh all action steps to get the final action step Upload to Google Drive to work.
One problem… I had attached multiple files to the new row, created the Zap sequence but still only one file uploaded (the first attachment). 
Is this because it’s just a free plan, or are there file size limitations, or after publishing the zap (with an upgraded or paid plan) the Zap sequence would actually upload all files attached to the row?
Here are screenshots of the Zap I built based on your guide:


Userlevel 7
Badge +6

Hi @NaNuVS,

When testing the Looping by Zapier, it will only create the first loop and won't go through all the loops during the test. To see the complete results, you'll need to actually publish the Zap. You can find more information about this over here:

You mentioned that you're currently using the free plan. Unfortunately, to publish a multi-step Zap (more than 1 action step), you'll need to upgrade to a paid plan. Take a look at the different plan features and pricing details here:

I hope this clears things up a bit! Feel free to reach out if you have any more questions. 😊

Userlevel 1

Hi @ken.a,

I am now signed in with my company’s paid account and trying to set up the multi-step Zap that you helped me build in the above thread.  I am on step 1 and running into an issue. 


There’s no place to type under “Trigger”.  

UPDATE:  Refreshed page and allowed to continue!

Userlevel 7
Badge +6

Hi @NaNuVS,

Awesome! Glad to know you were able to get it sorted!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 😊