Best answer

Trello Error: While requesting "attachments" from Trello, we ran into an error: The app returned "File not found".

  • 12 October 2023
  • 13 replies
  • 268 views

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

I need a help. I connected Trello and RD Station (marketing management) using the Zapier. But in some zaps happned this trouble: While requesting "attachments" from Trello we ran into an error: The app returned "File not found".

I don't use attachments, for this reason I don't understand.

 

 

icon

Best answer by ken.a 17 October 2023, 09:26

View original

13 replies

Userlevel 7
Badge +6

Hi there @Fabio Custódio,

Welcome to the Community! 🎉

I did some digging into this, and it seems like you’ve reached out to our Support Team about this, and this issue turned out to be a bug with Trello. I’ll share details of the Support Team’s suggestion here in case it’s helpful:

Thank you for getting back to me on this.

I have done some digging on the issue, and I see that a few other users have been running into the same problem. As it turns out, what we're seeing is a known bug.

A bug report is in place, and we'll get back to you immediately when a fix ships for the problem.

I’ve added your email to the list of affected users, which will help increase priority, and you’ll get a notification once this issue has been resolved.

As a workaround, Could you try to change the field where the non-file attachments are located on your Trello cards, and move them to the body of the card? This issue is happening because the Trello card has non-file attachments (URLs), but Zapier is not able to download them and gets an error 404 when trying to access them. See log.

Please let me know if this helps.

I am keen to hear back from you, and I'll be keeping an eye out for your reply. Thanks!

If you’ve got any questions regarding their suggestion it would be best to continue the conversation with them over email.

Thank you for your understanding.

Hi @ken.a, thank you for your answer. Try to change the field as non-file attachments are located on my Trello cards it’s impossible, because it depends on the process include. For this reason I use the Zapier, for help in my process automation. And this was happened in some cards, not in totally cards, it’s very strange.

Userlevel 1

We are experiencing the same issue with the same error message sending activity from Trello to Google sheets.  Any help or solution to this issue?

We are experiencing the same issue with the same error message sending activity from Trello to Google sheets.  Any help or solution to this issue?

 

The Zapier Support anwered me: Hi Fabio
Thank you for getting back to me on this.
I have done some digging on the issue, and I see that a few other users have been running into the same problem. As it turns out, what we're seeing is a known bug.
A bug report is in place, and we'll get back to you immediately when a fix ships for the problem.
I’ve added your email to the list of affected users, which will help increase priority, and you’ll get a notification once this issue has been resolved.

Please let me know if this helps. 
I am keen to hear back from you, and I'll be keeping an eye out for your reply. Thanks!
Regards 

Hello Guys, unfortunately we have the same problem. Makes our Trello Pipedrive connection basically useless...

Userlevel 2
Badge

This issue is critically impacting our operation!! 

We have a trigger “When a card moves to a list” and are trying to pass the card title to a Zapier Formatter action to simply encode the card title. The formatter step fails with the error “While requesting "attachments" from Trello we ran into an error: The app returned "File not found".”

On a different Zap we also trigger on “Card moved to list” and need to simple gather some info on the card to send an email on Gmail. It also fails with the same error.

On both cases the only attachments are other trello cards. 

These errors are occurring in highly automated systems and we have tens of Zap failures already. Each day is critical.

What is a timeframe we can expect to have this working?   

Thanks in advance

The error continues, I pay Zapier to make these automations easier. But it's not paying off.

Userlevel 1

We are having the same issue! We have a number of zaps that use Trello, and we’re getting “possible error” alerts for multiple zaps. Thanks for sharing this info! Definitely something we want to see resolved as well.

Userlevel 7
Badge +6

Hi friends,

I’m really sorry for the inconvenience this bug has caused you.

This is a known bug with the Trello integration. Our team is aware of the issue and is working on a fix. I've added your email address as another affected members. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

Hopefully, this helps.

Userlevel 2
Badge

Any news on this?

Userlevel 7
Badge +11

Hi there @sistemasUp! 👋

I’ve just checked on that bug report for you and it’s still open unfortunately. We can’t give any estimate as to when this issue will be resolve but, as Ken added you to the list of affected users you’ll definitely get an email notification from us as soon as it’s been fixed.

There was a workaround Ken mentioned earlier that might be worth trying, if you’ve not done so already? I’ll share the workaround again here in case it was missed:

“As a workaround, Could you try to change the field where the non-file attachments are located on your Trello cards, and move them to the body of the card? This issue is happening because the Trello card has non-file attachments (URLs), but Zapier is not able to download them and gets an error 404 when trying to access them.”


Hope that helps in the meantime. Really appreciate everyone’s ongoing patience on this. If we have any further workarounds or updates we’ll be sure to follow up here to share details of them with you all here.  

Userlevel 2
Badge

I cannot implement this workaround. My cards have other cards as attachements, which are used in automations in Butler and Zapier. Butler needs the attached cards to perform certain actions.

Let me just point out that this was working perfectly. It was something implemented by you guys that broke it, so maybe you could rollback until you have a working version of the code.

Userlevel 7
Badge +11

Sorry to hear that workaround won’t be suitable @sistemasUp.

Checking the bug report it appears to have been around for a bit longer than the date this thread was started. Can you confirm what date it was last working for you for non-file attachments? I’m wondering if there’s some difference between the recent runs of the Zap that worked and those that didn’t. Would you mind reviewing the Data In and Data Out tabs on your Zap History for some recent examples to see if you can spot any differences there? And if you do find a difference would you mind sharing a screenshot to show it here so that I can add those details to the bug report? Remember to remove/hide any private information (like names, emails, addresses etc.) from the screenshot before sharing.

Sadly, I can’t rollback the version on your behalf. Do you have any Zaps that were using an older version of the Trello app? If so you could potentially make a copy of those Zaps and recreate the desired other Zap steps in order to access the previously working version. 

Looking forward to hearing from you on this!

Reply