Best answer

This Microsoft SharePoint step hit an error Error message: The app returned "Locked".

  • 4 December 2023
  • 6 replies
  • 180 views

Userlevel 1

Good afternoon! I am running into an issue where my last action in a Zap returns the following message: This Microsoft SharePoint step hit an error. Error message: The app returned "Locked". The Cloudinary actions are to upload an attached image, then transform that image, then upload the transformed image to the folder that was created in the first action. What does not make sense to me is that each action works flawlessly when tested in the editor, but when I publish it and submit a new Jotform form, it results in this error. If I remove the Cloudinary actions and just use the image from the Jotform submission, it works fine. I’ve also tried various other Cloud storage options such as OneDrive and Google Drive and I receive the same error. It appears to be something with the Cloudinary actions but I’m not sure what to change since it works fine when testing in the editor. Any help would be appreciated.

 

icon

Best answer by darvinm 6 December 2023, 14:19

View original

6 replies

Userlevel 7
Badge +11

Hey @darvinm! 👋

Are there any access or security settings that were since enabled in Cloudinary that require someone to be logged in order to access the image file? If so, that could potentially be why the Microsoft SharePoint action isn’t able to access the image files. Do you think that could be the case or are the URLs generated by the Cloudinary actions publicly-accessible

If they are publicly-accessible, then perhaps the access issue may lie with the folder that was created. Has anything changed for the folder permissions-wise, since the Zap initially created it?

Alternatively, perhaps not enough time has passed since the folder was created before the Microsoft SharePoint action tries to upload a file to it. In which case, adding a delay of a few minutes before the upload a file action may help to give the Microsoft SharePoint API time to update and see the new folder. Bit of a long shot I know, but might be worth a try?

Looking forward to hearing from you on this!

Userlevel 1

@SamB Thanks for the reply. Here are some additional tests I did to reach the conclusion that it does not have anything to do with SharePoint.

  1. Instead of dropping the Cloudinary file in the created folder, I drop the Jotform file in instead and it works fine. This is why I do not think it has to do with the storage option, plus the fact that it did it for all storage providers I tried.
  2. Set the folder in the last action to a static folder vs a “Server Relative URL” which is the file path from the previous folder creation action. Still resulted in an error.
  3. I also tried the time delay, but same error.

The file is public as I can view the file even when I am not signed in to Cloudinary. Here’s a link to one of the files. As you can see, it is a public file and you can download it. One difference between the Jotform URL and that Cloudinary URL, is that the Jotform URL will download the file upon visiting the URL, whereas the Cloudinary URL just opens it in the browser. I discovered a way to make the Cloudinary URL automatically download the file (link here) but that results in the same “Locked” error message.

Again, I appreciate any help given.

Userlevel 1

@SamB I also just added a “Send Email from Outlook” action and an “Create Idea in Buffer” action (a social media management service) and both of these failed as well. This further confirms my suspicion that is has to do with Cloudinary and not any of the services that are trying to access the file.

 

Userlevel 7
Badge +6

Hi there @darvinm,

I’m jumping in to see if I can help!

I've had a look into the error you mentioned, but it seems like it's a unique one. For a bit more insight I’d recommend reaching out to our Support Team so that they can take closer look at the Zap and its logs to determine what’s causing this issue.

You can reach our Support Team here: https://zapier.com/app/get-help 

Hopefully, this helps.

Userlevel 1

@SamB @ken.a  Thanks for the input. I was able to figure out a solution after reaching out to Cloudinary support. It turns out that the transformation is only run the first time the URL is called, at which point the image is cached on their servers and is available for download. The transformation does take some time to process and the reason the error was happening is because the SharePoint action was timing out since there was no file available at the time it made the request. So a delay was needed but the delay needed to be between the first URL call and the upload request. The way I was able to work around this is to use the Web Parser by Zapier to perform the first URL call of the Cloudinary transformation URL, add a 1 minute delay, then use the same URL in the SharePoint file upload (see screenshot below). One thing to note is that the Web Parser setting “Continue on failure” needs to be set to true, as the result of the parse is going to be an error and will show that the Zap has failed.

I hope this solution helps someone else in the future!

 

 

Userlevel 7
Badge +6

Thank you for circling back and providing us an update. We appreciate it, @darvinm! This will be helpful to our other awesome Community members who might run into a similar challenge.

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 😊

Reply