Best answer

Task Links from Clickup are not unfurling when sent to Slack via Zap

  • 6 July 2023
  • 9 replies
  • 198 views

I have a simple zap that is triggered by the creation of a new task in Clickup.  The resulting action is a slack 

message that includes a hyperlink to the task.  Everything works fine except that the task link will not unfurl in the Slack chnannel whether the zap is sent by bot or as me.  Now that same task link will unfurl properly if I enter it manually as a user in Slack but not so via Zap.Any solutions would be appreciated.  See pics below

 

icon

Best answer by ken.a 6 July 2023, 13:00

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +14

Hi @MFD 

Good question.

Did you set the field for Auto-Expands Links to Yes?

 

Yes I did.  Did the screenshots not come through?

I see that not all the screenshots came through.  See below for the rest of the Zap setup


 

 

Also the screenshot below shows the difference between manual input on Slack and when Zapier sends the same link.

 

Finally this is what Slack support is saying.

 

Natasha (Slack)

Jul 5, 2023, 10:17 PM PDT

Hi Lucki,

Thanks for getting back to me.

I can see in our logs that we're sending the link_shared events to ClickUp and they're making the call to the chat.unfurl API, but this is failing with a cannot_auth_user error: https://api.slack.com/methods/chat.unfurl#:~:text=Description-,cannot_auth_user,-The%20current%20user`

This is because they're setting the user_auth_required to true which indicates the user who shared the link (Zapier in this case) must install the ClickUp app to trigger unfurls for their domain.

If it's possible to send messages on behalf of a user (who has authorised with the ClickUp app) from Zapier (also a third-party app), then that might help you get around this, but ultimately it is up to ClickUp to investigate further and handle this scenario appropriately. I'd recommend writing to them with this information and if they need further assistance debugging the issue, they can reach out to us directly via feedback@slack.com.

Kind regards,
Natasha

Userlevel 7
Badge +6

Hi @MFD,

I’m jumping in to see if I can help!

I did some digging into this, and it seems like this is a known bug with the Slack integration where links don't unfurl if the “Send as Bot” field is set as true. Our team is aware of the issue and is working on a fix. I've added your email address as another affected member. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of members affected by this issue so we can let you know as soon as we have any updates.

As a potential workaround you could first retrieve the link preview data, as per:

To then use the data from that step, and set auto-expand to No.

Hopefully, this helps!

The links will not unfurl went sent to Slack regardless of whether or not it is sent as a bot or user.

Userlevel 7
Badge +11

Thanks for letting us know, @MFD. Sorry the workaround suggested didn’t do the trick.

This is a bit of a long shot, but I wonder if you might be able to get around this issue using a API Request (beta) action for Slack - see: Set up an API request action. It’s a bit more advanced than setting up a Send Channel Message action as it would involve configuring the webhook to be sent to Slack but I’m thinking that may allow you to then set the user_auth_required to false so that it doesn’t have the same issue. 

Do you think that might work?

Otherwise, you could try creating a Slack app and use a Webhooks by Zapier action to send the message instead. Again, this is advanced but we do have a topic in Community that discusses how to post a message on Slack that’s formatted with different color bars, which references the same API endpoint you’d need to use (chat.postMessage). So that may be help to get you started:


Hope that helps, if you run into any issues implementing either of those other workarounds just let us know. Happy to assist further! 🙂

Yes that is advanced.  Thanks for the tip.  I guess I can look into it whenever I find the time.