Best answer

Sync from Google Calendar to Zoho Calendar - Time Format is Incorrect

  • 9 February 2024
  • 16 replies
  • 70 views

I have a Zap setup to create a Zoho Calendar event anytime a new Google Calendar event is made. The time in Zoho is incorrect. Zoho is dropping the 1 in front of 18:00 and 19:00 and making it 8:00 and 9:00 see below:

Both Calendars are on 12 hour time

Here are the run details:

Google Calendar: start: dateTime: 2024-02-09T18:00:00-05:00

Google Calendar end: dateTime: 2024-02-09T19:00:00-05:00

Zoho Calendar: start: 20240209T080000-0500

Zoho Calendar end: 20240209T090000-0500

icon

Best answer by SamB 6 June 2024, 16:06

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

16 replies

Userlevel 7
Badge +14

Hi @JamesLMartin 

For us to have full context, please post screenshots with how your Zap steps are outlined and configured, thanks.

 

 

 

 

Userlevel 7
Badge +14

@JamesLMartin 

Try adding a Formatter > Date & Time > Format step to the Zap.

You can adjust for time zones.

The time zones are correct, here is the diff between google and zoho: 

Google Calendar: start: dateTime: 2024-02-09T18:00:00-05:00

Google Calendar end: dateTime: 2024-02-09T19:00:00-05:00

Zoho Calendar: start: 20240209T080000-0500

Zoho Calendar end: 20240209T090000-0500

Userlevel 7
Badge +6

Hi there @JamesLMartin,

It looks like you’ve reached out to our Support Team about this and they replied today with a suggestion. I’ll share details of the suggestion here in case it’s helpful:

From what you've described, it sounds like the issue you're experiencing is with the time translation between Google Calendar and Zoho Calendar events. I understand how frustrating this can be, especially when dealing with important calendar events.

Based on the data you've provided, it appears that the time is being incorrectly converted to AM instead of PM when events are created in Zoho Calendar. I believe this could be due to the timezone settings between the two apps.

To help resolve this issue, I suggest checking the timezone settings in both your Google Calendar and Zoho Calendar to ensure they're identical. You can read more about this here: https://help.zapier.com/hc/en-us/articles/8496215472653-Zap-dates-or-times-are-incorrect

After you've done this, please try triggering the Zap again and see if the time on the Zoho Calendar event aligns correctly with the Google Calendar event.

Really appreciate your patience here. Looking forward to hearing back from you. Thanks!

If you’ve got any questions regarding their suggestion it would be best to continue the conversation with them over email. If you can’t locate their reply I’d recommend searching your spam/junk folder or searching your inbox for any emails from zapier.com in case. Sometimes their emails can end up in the spam/junk folder by accident.

I had originally checked that and the time zones are correct. I did notice that there was a difference in the format of the time zone: 5:00 v/s 500.  Will that make a difference? and if so, how can this be resolved? 

Google Calendar: start: dateTime: 2024-02-09T18:00:00-05:00

Google Calendar end: dateTime: 2024-02-09T19:00:00-05:00

Zoho Calendar: start: 20240209T080000-0500

Zoho Calendar end: 20240209T090000-0500

You can see in the data that the time zones are the same, correct?

Userlevel 7
Badge +6

Hi @JamesLMartin,

I’d recommend relaying this information with our Support Team since they have the correct tools to look closer at the Zap and its logs to determine the cause of the issue.

I appreciate your patience and understanding.

Experiencing the exact same issue. Not likely relevant, but maybe so: we’re also in the GMT-5:00 timezone. Trying a sync between Arlo events and Zoho calendar, every entry appears as if the first digit was truncated, just like JamesLMartin described. Confirmed our timezone settings are correct on both ends, and added a default time zone in case.

We’ve also set a default timezone in Zapier - if I recall, it’s described something like “time zone to use if we cannot read / discover embedded timezones from apps.”

Going to reach out to Zapier support, and wanted to add the record here for future visitors.

 

 @JamesLMartin have you resolved this issue? Just contacted tech support and received a reply saying “a bug report was filed, but we don’t know when it will be investigated.” So at this point, there’s not even a confirmation that this is a Zapier quirk. I’m wondering if this is a Zoho thing, so that’s the next item I plan to investigate… any updates from your end are appreciated.

I just tried doing a sync to Google Calendar instead Zoho Calendar. What should have been added as 17:10 was created as 07:10… so it again looks like the first digit was dropped. If this is a glitch, it now really appears that it’s introduced when getting processed by Zapier.

Userlevel 7
Badge +11

Hi @JamesLMartin and @Bytech

I checked on the bug report Bytech mentioned and it appears that Zoho’s developers have been able to identify the cause of the issue and are working on getting a fix in place.

I’m unable to share any details on when you can expect a fix to be implemented by but you’re both on the list on folks being impacted by this issue so you’ll receive an email notification from us as soon as it’s resolved.

Thanks for your patience in the meantime! 🙂

Userlevel 7
Badge +11

Hey folks, 

Just following up here to share that the bug report has been closed! 🎉

The Zoho team has recently released an update which should resolve these issues with the Create New Event action. To take advantage of this fix you’ll need to ensure you’re running the latest version of the Zoho Calendar app in your Zaps. You can find out how to do that here: Update to the latest app version in Zaps

We hope you’re able to test this out soon. And if you’re still running into any issues reach out in the Community or contact Support directly and we’ll be happy to assist further. 

In the meantime, happy Zapping all! ⚡