Best answer

Stripe custom field not appearing in Zap

  • 2 July 2023
  • 3 replies
  • 456 views

I have a Stripe checkout page (see screenshot) that has “email”, “name on card”, and two custom fields for “first name” and “last name”. By default Stripe brings through “name on card” as “name” and we were using that with a splitter function in our zap. However, sometimes the name on card is just an initial .e.g “J Adams” so our CRM was bringing through “J” as the first name. 

We added First Name and Last Name to the Stripe checkout page however these two custom fields are not coming through to Zapier. I have loaded a new customer from stripe and it sees it in the test data in Stripe. Any help appreciated. I’ve tried recreating the zap from scratch and it’s not pulling through.

 

icon

Best answer by ken.a 3 July 2023, 07:49

View original

3 replies

Userlevel 7
Badge +6

Hi there @kwhitmore,

Welcome to the Community! 🎉

I did some digging into this, and it seems like custom fields are not yet supported by the Stripe integration. Also, I haven’t found any open feature request to support custom fields on the “New Customer” trigger.

I recommend reaching out to our Support team to have them create a feature request on your behalf. You can contact our Support team here: https://zapier.com/app/get-help

7cf4459bc2c0101f1790f9db385a8e46.png
(view larger)

Hopefully, this helps! 😊

I ran into a similar issue today. After swapping over to using the webhook from Stripe, I was able to see all of my custom fields.

 

 

I ran into a similar issue today. After swapping over to using the webhook from Stripe, I was able to see all of my custom fields.

 

 

Lockeyg, happy to hear that you managed to get it working. How did you swapped to using webhook from Stripe?

Reply