Best answer

Squarespace to Flodesk Integration Error - The "segments.0" must be a valid "[ObjectId]"!

  • 4 July 2023
  • 9 replies

Userlevel 1

I am setting up my first Zap to integrate my Squarespace website with my Flodesk account.  I set up the trigger and ran the test with no issue.  

When I went to the next step in the Zap (Create/Update user in Flodesk) I am able to get the fields I need from my Squarespace form fields just fine, but the testing error I get is: The "segments.0" must be a valid "[ObjectId]"!

I double checked and the segment name matches the name I have set up in Squarespace.


Best answer by ken.a 6 July 2023, 07:43

View original

9 replies

Userlevel 7
Badge +11

Welcome to the Community, @Chef Alicia

The error seems to be saying the value that’s been supplied into the Segment field isn’t a valid ID. If you’re using the segment name and it’s expecting to receive the segment ID number then that could be it.

In which case you might need to create a lookup table that converts the segment names into the relevant segment ids from Flodesk. If you click into the Segment field on the Flodesk action you should be able to see the ID for each segment written in grey text underneath it.

You’d then use those ids in a Formatter (Utilities > Lookup Table) action to make the lookup table. If you’re not familiar with lookup tables we have a helpful guide with more details here: Create lookup tables in Zaps

Hope that helps. If you run into any issues or questions on that at all please let us know, happy to further assist! 🙂

Userlevel 1

Hi Sam!  Thanks for the feedback!  I created the lookup table with the ID with the segment but I guess maybe I’m now not sure what the corresponding field name should be in the table to look up against.

In the first field, I did the code then the second field I did the segment field name.  Is that correct?

I’m still getting the same error so that’s why I’m not sure if I’m doing it right!

Userlevel 7
Badge +6

Hi there @Chef Alicia,

I’m jumping in to see if I can help!

The error The "segments.0" must be a valid "[ObjectId]"! you’re seeing is due to the incorrect selected data in the “Segment” dropdown field. Could you please try selecting the correct segment in the “Segment” dropdown field?

(view larger)

Please keep us posted! 😊

Userlevel 1

Hi Ken,

   Thanks for jumping in!  When I click on segment there’s nothing in the dropdown field to choose.  I’ve attached all the screen shots of everything between Squarespace and Zapier so I hope these also help.


Userlevel 7
Badge +6

Hi @Chef Alicia,

Thanks for the screenshots!

Quick question, did you create a Segment on your Flodesk app? If not, I suggest creating a Segment first then reconnect your Flodesk account here: that, head back to the “Segment” field in the Flodesk action step to see if it’ll load the Segment.

Please give that a try, and let us know how it goes! 😊

Userlevel 1

Hi Ken - this solved my issue!  I was using the Squarespace mailing list block instead of inserting the code from Flodesk to create the mailing list block!  I can now see the test email from my website in Flodesk!  I really appreciate everyone’s help!  If you couldn’t tell I’m a first time user with Zapier and Flodesk :)

Userlevel 7
Badge +6

Hi @Chef Alicia,

I'm glad to hear that your issue has been resolved!

No worries about being a first-time user with Zapier and Flodesk. Everyone starts somewhere, and it's fantastic that we were able to point you to the right direction!

Don't hesitate to reach out if you have any further questions or if there's anything else we can assist you with. Happy Zapping! 🚀

Hi @ken.a - I am actually having the same problem as @Chef Alicia

I have unlinked and relinked my Flodesk account as suggested in one of the messages above.  I uploaded my contact to a new segment in flodesk and when I search for the segment name in a zap action, nothing comes up at all.  Almost as if there aren’t any segments created but I have two in my flodesk account. 

New to Zapier and really looking forward to automating but need to get it straighten out first!  

Any help is much appreciated! Thank you 


Userlevel 7
Badge +6

Hi @Amanda_aligned,

I’m so sorry for the late response here.

Have you managed to solve the issue that you’re running into? If not, please let me know. I’d be happy help troubleshoot further.