Question

Spreadsheet updates not pulling into test records

  • 4 April 2024
  • 1 reply
  • 10 views

I’m creating a signup sheet with timeslots for people to enter in their emails. The idea is for the zap to find the event if it exists and update and if not, create the event. I have 3 columns with headers. When I update the 3rd column with my email to start testing, Zapier isn’t pulling in any of these as test records. It’s only registering updates to the other columns. What do I need to do to change this?

Col A is Group, Col B is Time - both of these stay static. Col C is Resource.

 


1 reply

Userlevel 7
Badge +11

Hi @Alison, welcome to the Community! 🎉

I can see that you’ve also reached out to our support team who have replied with suggestions on how to get a new test record. I’ll share the main details from their email here in case it’s helpful for others running into similar issues:

From what you've described, it seems like you're having some trouble with Zapier not recognizing updates specifically to the "Resource" column in your spreadsheet during testing. I can understand how this could be puzzling, especially when you are trying to ensure everything is set up correctly.
 
No need to worry, as this behavior is quite normal during the testing phase of setting up your Zap with this trigger. The test records should have the representative fields you need, and you can use those when mapping downstream values. Once your Zap is published and turned on, any updates to the "Resource" column will trigger it as expected.
 
However, if you need a value in the "Resource" field for testing purposes, there are a couple of options you might consider:
 

  1. Create a new row in your spreadsheet which has an email in the "Resource" field. I understand this isn't your end goal but it will give you some data to work with when setting up your Zap.
  2. You could also modify an existing test record by following the instructions in this guide: Change the test record in your Zap trigger

 
To sum it up, the testing phase in the Zap editor might not behave exactly like your live Zap. But rest assured, once your Zap is live, it should work just fine with updates to the "Resource" column.

 

Hope that helps. If you’re still having trouble getting a new test record or have further questions do let us know! 🙂

Reply