Best answer

Splitwise Zap suddenly stopped working - Currency Code Splitwise does not support the given currency code

Userlevel 1

Hi all, 


wondering if anyone has any thoughts on this error i’m getting. 


I had a zap that I’ve been using for months that takes an amount from my YNAB budget and automatically creates an expense in Splitwise. A week or two ago I started getting these errors every time I try and run it. 


I’ve tried reformatting the amount to convert it to a currency and adding a dollar sign in front of it but nothing seems to be working. 


Best answer by Danvers 7 February 2023, 10:24

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

13 replies

Userlevel 7
Badge +14

Hi @novawaly 

Good question.

Can you provide the currency code used that resulted in the Zap step error?

Userlevel 1

@Troy Tessalone where would I find that? I’m comparing an old run and when I get to the final step, there is a lot more information being passed  to splitwise including a field called currency_code:


versus the one i’m running now - seems to only be passing a few fields:


Userlevel 7
Badge +14


If the currency code will always be the same, then you can set a static selection or value. (e.g. USD)


Otherwise, if you were mapped the currency code from the Zap trigger step, then check/test why that is no longer coming thru.


Or to prevent the errors, you can add a Filter step as step 2 to check that the Zap trigger included the currency code.


Supported currencies

Returns a list of all currencies allowed by the system.
These are mostly ISO 4217 codes, but we do sometimes use pending codes or unofficial, colloquial codes (like BTC instead of XBT for Bitcoin).

Userlevel 1

@Troy Tessalone  I’m sorry - im not quite following. 

I’ve never had to provide a currency code before. I tried running a zap from 6 months ago that worked without a problem.

next - i just multiply the amount by 2 and the final step is just sending it to split wise. There is no selection or input anywhere that asks for a currency code. I’ve also verified that the zap from 6 months ago that ran successfully, is now giving me the same error. 


It seems as if Zapier is no longer retrieving or sending the same data as it used to?



As I mentioned, I tried adding a currency conversion where I change the amount to be in USD (which it will always be) and it still gave me the same error so I dont think it has to do with the number I’m passing

Userlevel 7
Badge +14


Probably best to open a ticket with Zapier Support for help troubleshooting:

+1 also experiencing this.

+1 on this issue.

+1 also having this issue

same issue here

Userlevel 7
Badge +12

Hi everyone!

This looks like a bug that has popped up in the last few days. I’m sorry that it’s causing trouble with your Zaps and we’ll look into it as soon as possible. 

@el322@Jeremy B@EnumC@zachk and @novawaly I’ve added you all as affected users on this issue, which lets the team know how many users are having this problem and also means that we’ll send you an email when it’s been fixed. We’ll also update this thread if/when we have some news. 


Userlevel 1

FYI this is a bug caused by an unintended breaking change to Splitwise’s API which now requires `currency_code` to be provided (even though the docs don’t call out this parameter as required). They’ve said that a fix will be out shortly, but in the meantime if you provide `USD` as `currency_code` the requests should complete as before.

Looks like the Splitwise create expense task in my Zap just ran successfully, so with any luck the bug is fixed

Userlevel 7
Badge +11

Thanks so much for sharing that information and helpful workaround here, @goleary! 🎉

Glad to hear the Create Expense action is working correctly, @Jeremy B! I’ve just checked and the bug is still open at the moment but we’ll be sure to email you all and post an update here as soon as it’s closed. 🙂