Best answer

Sending Facebooks posts to Google My Business Profile - error getting image/video url

  • 11 January 2023
  • 4 replies
  • 331 views

Userlevel 1

Hi everyone,

I’m trying to Zap my Facebooks posts over to Google My Business.

I keep getting errors in the testing.

The error I get is “Couldn't create a post for this location: Request contains an invalid argument”.

I have several GMB accounts/locations under my gmail. And I have access to all the Facebook pages and the GMB’s.
 

I can’t seem to get this working and it’s driving me nuts!

Thanks!

 

 

 

icon

Best answer by SamB 16 January 2023, 17:47

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 1

Update:
If I put “Message” in the Summary and leave the [Photo URL field] blank, it will send the caption from Facebook to GMB.

But I’m not sure what to put in [Photo URL] to get the photo/video to go across as well?

Any help on this?

Thanks

Userlevel 7
Badge +11

Hi @Shannon982! 🙂

I expect you’re getting a “Request contains an invalid argument” error here as the Photo Source URL field is expecting to receive a publicly-accessible link to an image, not a link to a video post on Facebook. 

If you put the link to the video in the Summary field but leave the Photo Source URL blank does it go through ok and display the video? 

Userlevel 1

Hi @SamB
Thanks for taking the time to respond. So I tried that and it literally just sends the link as text to the GMB Profile! Let me show you…

The link is using the “Link” option which is the Facebook video post url...
 

 
And this is how the post got sent to GMB. Literally the text from the link. Not what I was expecting lol.

 


 

Userlevel 7
Badge +11

Thanks for giving that a try here @Shannon982! I’m so sorry to hear it didn’t work as hoped. 

I’ve done some further digging and discovered that there’s actually a feature request for the ability to have video links supported with the Google My Business app. So it looks like it’s not going to be possible to use a video link here at the minute.

I can see our Support folks have already submitted your vote for that feature request to be added. That means we’ll be able to alert you by email as soon as it’s added to the Google My Business app. We’ll also be sure to post any updates in the thread here as and when they occur. Hopefully the wait on that won’t be too long! 🤞