Best answer

Schedule Trigger Not Working

  • 17 February 2022
  • 9 replies

I have tried setting times for this zap numerous times and it never seems to work. As you can see I have a Schedule trigger with a time (and a time zone of set to Denver with me in Colorado Springs) and Delay and it never seems to fire. I need to make sure this test Zap is working before I deploy it on another Zap.

I have tested each step and there are no errors.

Any ideas how to get this to work correctly?



Best answer by Steve Eller 17 February 2022, 17:29

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +14

Hi @Steve Eller 

Have you tried turning the Zap ON and testing live?

Check your Zap Runs for troubleshooting clues:

Did the Zap trigger?

Did the Zap trigger but error on a step?

Yes, it is on and I have tested live. It’s not triggering at all. That’s the problem. When I set the time it never triggers. There are no errors and no successful runs.

Userlevel 7
Badge +14

@Steve Eller 

Probably best to open a ticket with Zapier Support:

I’m scheduling it as an every day at a specified time. I’m wondering if it has to wait until the next day and then the specified time to work. I’m going to try using the “every hour” setting and see if it works.

@Troy Tessalone I have done that and have yet to hear anything back.

Userlevel 7
Badge +14

@Steve Eller 

Make sure to check your junk/spam folder and try searching your inbox for “” to see if somehow the email got filtered/filed.

@Troy Tessalone yeah, I’ve done that and I haven’t received anything.

Userlevel 7
Badge +9

Hi @Steve Eller! Thanks for reaching out. I took a quick peek at the ticket and it sounds like you may have gotten this sorted. We’d love to hear what your solution ended up being! 🙂

@christina.d see the answer in this thread.:point_up_tone1: