Salesforce Integration error - can't load 'Salesforce Object' data

  • 24 March 2022
  • 1 reply

We are having a problem with our Zaps connected to Salesforce since yesterday.

The error message we get is:

We’re having trouble loading 'Salesforce Object' data (Received an unexpected response from Salesforce when getting the list of createable objects.)

We tried to resolve with all the steps from the documentation without success:

  • Hard refreshing the page (Shift+F5 on a PC or CMD+Shift+R on a Mac) a couple times
  • Click ‘Refresh fields’ at the bottom of the Zap step
  • Copy that Zap and edit the copied version to see if the fields appear
  • Recreate the Zap from scratch
  • Wait a while longer, sometimes it takes a little while for the cache to refresh with those fields

Also tried another step by re-connecting the account under myApp interface. The connection seems to be ok.

There was a similar issue reported a few months ago, but the thread is unresolved and closed.

Can you please let us know if you have experienced a similar issue and/or how to fix it? 

Thanks for your support

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +14

Hi @accountDFS 

Might be best to open a ticket with Zapier Support for help.

Error: "we’re having trouble loading ‘Object’ data"

If you run into this error, this means we couldn't find new objects with the name "" or that we're currently not able to use this object type.

You can report this to support.