Salesforce error: Failed to create a contact in Salesforce; Could not create record of the "Contact" object: Duplicate record.

  • 24 February 2023
  • 5 replies

Hi all!

I am running into issues when writing a zap that would create an account and update/create a contact in Salesforce (update when email is present, create when it is not).

Step 4 is the “Find record” step where I lookup if email is in salesforce. If that is false, the path leads to a create contact step. But when I try to create the contact, I get the following error message: 

Which is confusing because the reason why it is pathed this way is because there is no email present, and I double check this email is not present in our CRM across all objects. This error goes away when I remove the email from the creation step, but the email is a necessity in our crm. It also works when I just put a dummy email in as the used email. Here’s what I’ve tried so far: 

  • mapping the email into just an unused text field (and was going to copy the email once in Salesforce via flows) - still got the error message.
  • reformatting the email via formatter and pulling the email the “create contact” step, versus pulling it from the trigger query. 
  • Using a “find record” step and selecting “create record if not found” box. I don’t get the exact same error, but another duplicative error with different wording
  • I Tried uploading just the account with the email, phone, and main point of contact name and then created a salesforce flow that would create a contact when the conditions are met, but I then get an error in zapier that the flow is halting the zap due to duplication.

Any ideas how to troubleshoot or what I may be missing? 

5 replies

Userlevel 7
Badge +14

Hi @dustin.jones.qwick 

Good question.

We’d need to see more screenshots with how all of your Zap steps are configured in order to have enough context.

Also, check the duplicate rules configured in Salesforce as that may be the root issue.


I am having this exact same problem but with LiveChat. It is constantly throwing an error of duplicate record, when I can confirm that isn’t the case. I have double checked duplicate actions in SF and nothing has changed. Following in case there is a suggestion! 

Userlevel 7
Badge +11

Hi @dustin.jones.qwick and @jennwalsh710!

As Troy mentioned, you can check the duplicate rules.

This may not be exactly what you see, since this is from an older internal note, but it would be something like this:


Our support team would be able to dig in a bit more, maybe check our logs to see if there’s any additional information that helps track down the problem (like the existing record that Salesforce is saying is the duplicate).

@nicksimard I checked the duplicate rule and they match your photo. I have had this set up for over a year and it just quit working about 6 weeks ago and to no avail is anything working.

Userlevel 7
Badge +11

Hi @dustin.jones.qwick and @jennwalsh710! 👋

I believe the Salesforce search is “fuzzy” so it may be that it’s finding a match based on some other values. Are you able to run a search for one of the contacts that’s getting a duplicate error in Salesforce directly? I’m wondering if seeing the details for the duplicate that it’s finding might help to give some insight as to why it’s being seen as a duplicate by the Zap? 

If that doesn’t help to identify why the contact was found then your best bet here would be to reach out to our Support team, as Nick mentioned. They’ll be able to dig into the logs for the Zap and investigate further! 

Please do keep us in the loop on how you get on here!