Best answer

Salesforce Error: Error Testing Connection

  • 15 February 2023
  • 6 replies
  • 314 views

All of a sudden our Salesforce connections are not connecting. No changes have been made in Zapier or SF. I have tried 3 system admins from SF and all get me a failed connection errors.  Really at a loss here

I have tried incognito..safari, etc.  No luck

I get prompted for SF MFA..and to allow the connection..then nothing ...

icon

Best answer by SamB 27 February 2023, 14:31

View original

6 replies

Userlevel 7
Badge +11

Welcome to the Community, @peterEarnnest! 🙂

I’ve done a quick check on our end and I’m not seeing any open issues or incidents related to accounts failing to reconnect successfully. 

Do the error messages give any additional details as to why it’s not connecting or does it just say “failed connection”? Asking as we can’t see into your account or Zaps here so I’m wondering if the full error message might help to give some additional clue on what’s preventing it from connecting to Salesforce as expected.

Looking forward to hearing from you!

No...all I see are these screens.  This started just yesterday

 

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Furthermore...the user Im using Is getting into SF

 

Userlevel 1
Badge

I’m having the same problem, although I’ve never been able to successfully connect to the newer Salesforce app. I had to use the Salesforce (Legacy) version, which is now depreciated. 

The Salesforce connection immediately expires after authorizing. I’ve tried multiple browsers and private/incognito mode. 

If I go to “My Apps” in Zapier and test the connection, it prompts me to reconnect Salesforce but the status never changes. If I test the connection, the only error message I get is “Error testing connection.”

My organization is not using a custom domain. And I do not have more than five OAuth Connected Apps in my Salesforce account. 

Does anyone have insight into what might be going on? 

(For what it’s worth, I am able to use Airtable’s integration with Salesforce to directly connect those two apps. That works just fine, so the problem seems to be on the Zapier side.)

 

 

 

Userlevel 7
Badge +11

Hi @peterEarnnest and @aaron_avl! 👋

@peterEarnnest, it looks as though you also reached out to our Support team about this and they’ve made some suggestions. I’ll share those here in case it’s helpful to @aaron_avl, and others in Community too! 

Just to make sure I'm on the same page as you, are you saying that the connection to your Salesforce account keeps getting disconnected and needing to be reconnected?
 
If so, then it could be due to some settings in your Salesforce account that are causing them to frequently invalidate the auth token used to keep that account authorized.
 
Because of that, I'll want you to first log into your Salesforce account, and disable the following settings in:
 

  • Lock sessions to the IP address from which they originated
  • Lock sessions to the domain in which they were first used
     

Screenshot of roughly what those settings sound looks like:
 
8c556dbfb4691d7ed8a60ed13714a239.png
 
(view larger)
 
Also, here's a guide from Salesforce that talks about adjusting those kinds of settings:
 
https://help.salesforce.com/s/articleView?id=sf.admin_sessions.htm&type=5

If you do manage to solve this by adjusting the session settings within Salesforce please let us know. Want to make sure you’re both get this sorted! 

Userlevel 1
Badge

Thanks @SamB; that appeared to have worked. Our Salesforce account is staying connected to Zapier. 

 

I’ll keep testing and follow up if I experience any other issues. Thanks!

Reply